Chrome-related: How to have the active page node highlighted in the navigation tree

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Post Reply
Joywang123
Posts: 4
Joined: Thu Oct 15, 2020 9:45 am

Chrome-related: How to have the active page node highlighted in the navigation tree

Unread post by Joywang123 » Fri Oct 16, 2020 1:56 am

When I open a Webhelp (index.html) using Chrome, any page node that I clicked in the navigation tree (TOC) is not highlighted (like with a darker background). But if I use IE to open the file, the page node is highlighted in the tree after I enabled the ActiveX following the tip message.

I'd like to know if it's a known issue with Help&Manual 7.

Thanks

User avatar
Tim Green
Site Admin
Posts: 21901
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Chrome-related: How to have the active page node highlighted in the navigation tree

Unread post by Tim Green » Fri Oct 16, 2020 8:25 am

Hi Joy,

What is happening here is simply that you are opening WebHelp directly from the hard disk in Windows, by double-clicking on an HTML file in the WebHelp folder. Then WebHelp is not being opened in a web server, which is necessary for WebHelp -- that is why it is called "Web"Help. As soon as you put it on your web server (Internet or local intranet) and access it from a browser with a regular http or https URL then you will not have this problem.

If you need local documentation without a web server you need to use a local format, for example Help+Manual's eWriter format, or Microsoft CHM help files or PDF.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

Joywang123
Posts: 4
Joined: Thu Oct 15, 2020 9:45 am

Re: Chrome-related: How to have the active page node highlighted in the navigation tree

Unread post by Joywang123 » Sat Oct 17, 2020 4:38 am

Thanks, Tim. Now I learned why webhelp works well on a remote server.

I have a further question about Webhelp in a web application that is deployed on a local machine.

I deployed my web application (with the WebHelp integrated) on my local pc. I access the the application in Chrome by typing http://localhost:<port number>, and then open the Webhelp in the application, the active page is NOT highlighted. Is it normal behavior for Webhelp? Looking forward to your reply. Thanks, Joy

User avatar
Tim Green
Site Admin
Posts: 21901
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Chrome-related: How to have the active page node highlighted in the navigation tree

Unread post by Tim Green » Sat Oct 17, 2020 8:28 am

Joywang123 wrote:
Sat Oct 17, 2020 4:38 am
I deployed my web application (with the WebHelp integrated) on my local pc. I access the the application in Chrome by typing http://localhost:<port number>, and then open the Webhelp in the application, the active page is NOT highlighted. Is it normal behavior for Webhelp?
Which skin are you using for your WebHelp? This is relevant here because the problem is the way the URL is parsed to activate the referenced page.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

Joywang123
Posts: 4
Joined: Thu Oct 15, 2020 9:45 am

Re: Chrome-related: How to have the active page node highlighted in the navigation tree

Unread post by Joywang123 » Mon Oct 19, 2020 4:57 am

The skin it's using is "Webhelp, Two Frames Classic Skin Silver.hmskin", which is provided in ...\HelpAndManual7\Templates\HTML Skins\Webhelp, Two Frames Classic
Thanks,
Joy

User avatar
Tim Green
Site Admin
Posts: 21901
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Chrome-related: How to have the active page node highlighted in the navigation tree

Unread post by Tim Green » Mon Oct 19, 2020 8:44 am

Hi Joy,

Don't use the "Classic" skins any more. They are only for legacy applications in old environments that still use very old versions of Internet Explorer.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

Joywang123
Posts: 4
Joined: Thu Oct 15, 2020 9:45 am

Re: Chrome-related: How to have the active page node highlighted in the navigation tree

Unread post by Joywang123 » Mon Oct 19, 2020 2:44 pm

Thanks, Tim. Yes, it works when I choose non-classic template.

I'm new to the Help+Manual, and having an urgent task to generate a Webhelp this Friday. Could you please give me some clues about how to quickly learn customizing a skin based on the free templates that are provided in the Help & Manual 7?

Plus, may I ask a quick question? How can I remove below text in the top right of Webhelp, Integrated IFrames Green Header.hmskin. I figured out how to change the background color and logo, but no idea how to remove the text.

After opening the skin, go to Configuration > Publishing Options > Webhelp > Layout to customize this frame page. Modify the header background and size, change the menu entries and apply your CI to this skin! Tip: If you export a project with this skin, make sure that you enable the option "Include Menu"!

User avatar
Tim Green
Site Admin
Posts: 21901
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Chrome-related: How to have the active page node highlighted in the navigation tree

Unread post by Tim Green » Mon Oct 19, 2020 3:21 pm

Hi Joy,

When you open the .hmskin file in Help+Manual (it can be edited just like a project) you will find the text you are looking for in the Source Code tab in Configuration > Publishing Options > Webhelp > Layout, as indicated in the text itself.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

Post Reply