Restoring Compatibility with Current Tortoise SVN

HM5 served us well, now its time has come and it has been replaced... If you have HM5 questions, please post them here.

Moderators: Alexander Halser, Tim Green

Restoring Compatibility with Current Tortoise SVN

Unread postby Tim Green » Thu Aug 11, 2016 4:35 pm

IMPORTANT: This works for both Help+Manual 7 and Help+Manual 6

As you will know if you use Subversion, recent changes to the Tortoise SVN client have made it necessary to downgrade to Tortoise SVN 1.9.2 to maintain compatibility with Help+Manual 6 and 7. This is potentially problematic in the long term, because it means that your version of Tortoise may no longer match the current version of your Subversion Server.

We now have a solution for this that works for both Help+Manual 7 and Help+Manual 6. We are going to provide more integrated support for it in the next update to H+M 7, but you can install the solution now and it will work fine. All you need to do is update Tortoise and then install the current 32-bit SVN client from Collabnet. The download is free, but at the moment you do need to register with Collabnet to get it. We are looking for a better solution for this.

All components must have the same version!

The only caveat is that you must make sure that all components have the same version. The version number indicates the Subversion version, so currently your Subversion server, Tortoise and the Collabnet client should all be version 1.9.4. If you update any of the components in the future you should update ALL of them to the same number again.

Step 1: Update Tortoise to the current version

This is Tortoise SVN 1.9.4. It is important that you DON'T use 1.9.3 -- that was an intermediate version and it will continue to confuse Help+Manual's SVN client access. You can always download the current Tortoise SVN version on this page:

https://tortoisesvn.net/downloads.html

Step 2: Download and install the 32-bit Collabnet client

When you click on the download link on this page you will first need to complete a free registration with Collabnet before you can proceed:

http://www.collab.net/downloads/subversion

IMPORTANT: You ONLY need the 32-bit command line client, even on 64-bit Windows. In the current version this is titled "Subversion 1.9.4 (Windows 32-bit)" and is 6.16MB. This is the only component that is missing to make the current version of Subversion work properly with Help+Manual.

collabnetdownload.png

After downloading, run the installer and accept the default location it chooses for installation.

Step 3: Restart Help+Manual

Subversion functions should now work properly without any further action on your part. In the unlikely event that there are problems, select the Collabnet client manually in View > Program Options > Subversion. It is installed in C:\Program Files (x86)\CollabNet\Subversion Client and the file you need to select is "libsvn_client-1.dll".
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19495
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Return to Help & Manual 5 Forum

Who is online

Users browsing this forum: No registered users and 2 guests

cron