'Broken' underline in links (pdf)

Please post all questions relating to Help & Manual 6 here!

Moderators: Alexander Halser, Tim Green

'Broken' underline in links (pdf)

Unread postby tatiana » Wed Jun 05, 2019 12:59 pm

Hello,

When I generate pdfs, the underline in some of the links appear to be 'broken'. Sometimes it looks OK, but sometimes it doesn't, and I cannot figure out what's causing it. The attached images show a normal-looking underline and a broken one. The links work fine in both cases.

Tatiana
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
tatiana
 
Posts: 4
Joined: Wed Jul 14, 2010 9:56 am

Re: 'Broken' underline in links (pdf)

Unread postby Tim Green » Wed Jun 05, 2019 5:07 pm

Hi Tatiana,

Two things here: Make sure that you are using the latest version of Help+Manual 6, which is 6.5.6 Build 3027 (check with Help > About). If you aren't you can download the free updater for that version here:

https://www.helpandmanual.com/downloads.html#oldver

Also, make sure that you are not using non-breaking spaces or any formatting changes within the links where this is happening.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20897
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: 'Broken' underline in links (pdf)

Unread postby tatiana » Mon Jun 10, 2019 6:53 pm

Hi Tim,

Sorry for the delay.
Yes, I'm using the latest version, 3027
There aren’t any non-breaking spaces in the links. They look like this even when I create them from scratch and just type in the link text manually.
There are non-breaking spaces before the links though (between 'fig.' and the link). But when I remove these, it does not change anything.
The formatting seems to be the same within the links.
I thought the reason could be that the links sometimes span two lines (they are always broken if they are on two lines). However, I have links that consist of just two words, are on a single line, and still are 'broken'.
I attached the image that shows what my links can look like.
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
tatiana
 
Posts: 4
Joined: Wed Jul 14, 2010 9:56 am

Re: 'Broken' underline in links (pdf)

Unread postby Tim Green » Tue Jun 11, 2019 2:43 pm

Hi Tatiana,

This is a very old problem in the old version of Help+Manual that we haven't dealt with in a long time. I had forgotten the cause, but I think it only showed up when you were using justified text. What happens is that the PDF engine inserts additional space characters to justify the text that are not the same as the normal spaces and that gives you the shift in the underline. I think the solution to this was to replace any spaces in links with non-breaking spaces, which you can insert with the Symbol tool in Insert Object in the Write tab. Then no additional spaces will be inserted there and you won't get the problem.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20897
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: 'Broken' underline in links (pdf)

Unread postby Tim Green » Tue Jun 11, 2019 4:14 pm

Hi Tatiana,

Update: This issue should actually have been fixed in HM 6.5. If you continue to experience it please mail me a small demo project and the .mnl PDF template you are using to support AT ec-software.com (replace the AT with @) and we'll check it for you. :)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20897
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: 'Broken' underline in links (pdf)

Unread postby tatiana » Thu Jun 13, 2019 1:21 pm

Thank you Tim, adding non-breaking spaces fixed it.
tatiana
 
Posts: 4
Joined: Wed Jul 14, 2010 9:56 am


Return to Help & Manual 6 Forum

Who is online

Users browsing this forum: No registered users and 4 guests