autoTabs: issue in html

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

autoTabs: issue in html

Unread postby dgalenkamp » Fri Aug 28, 2015 2:50 pm

Hello,
We are new users and are running into a problem that we cannot seem to figure out the answer to.
Every time we generate a web help file using any of the premium pack (2.70) html skins, the index page, on line 76, contains the following
Code: Select all
autoTabs: "<%AUTO_TABS%>",
.

When we run just the straight HTML it runs fine but when we publish it to our server to run through IIS it throws a compilation error 'AUTO_TABS' is not declared.
While I understand that our server setting is part of the problem (we are layering on a security control which requires certain settings on the server and are not willing to change that for the help tool) and we can get around it by manually changing the code to say autoTabs:True, I would really like to figure out where that is happening and fix the issue.

this is the code block with the issue:
Code: Select all
// Navigation pages
var hmnavpages = {
   toc: "hmcontent.html",
   tocWidth: 275,
   idx: "hmkwindex.html",
   sch: "hmftsearch.html",
   top: "index.html",
   def: "toc413752555.html",
   query: window.location.search.substring(1).replace(/:/g,""),
   hash: window.location.hash,
   cachefix: false,
   autoTabs: <%AUTO_TABS%>,
   userReload: false && window.location.search == "" && window.location.hash == "",
   checkChrome: true,
   printHL: true,
   share: false,
   banneroff: false,
   loadCount: 0,
   mainWindowName: "",
   isEWriter: false
}


Any help would be appreciated,

Dan
dgalenkamp
 
Posts: 1
Joined: Tue Aug 25, 2015 8:30 pm

Re: autoTabs: issue in html

Unread postby waldemar.hersacher » Fri Aug 28, 2015 9:31 pm

You have to define a variable named AUTO_TABS.

For more informations see Navigation: Help & Manual Premium Pack > WebHelp Skins: Auto-Tabs / Reopen Tabs in the help of the premium pack.

Otherwise you need to change the file hmVars.js in the baggage files of the skin. Change autoTabs: "<%AUTO_TABS%>", to autoTabs: "",
Waldemar
User avatar
waldemar.hersacher
 
Posts: 455
Joined: Tue Dec 09, 2003 10:06 pm
Location: Near Stuttgart Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron