TOC not expanding on load

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

TOC not expanding on load

Unread postby Ed Hawco » Fri Jul 22, 2016 5:31 pm

I have "On load, expand all entries" enabled in "Publishing Options > Webhelp > Navigation," yet when I compile the webhelp the TOC items are not expanded. Or more precisely, only the "Default topic" item is expanded.

"Automatically collapse unfocused entries" is NOT selected.

Any idea what might be going on here, or how I can get all items to expand?
e
d
============================================
Ed Hawco
User avatar
Ed Hawco
 
Posts: 137
Joined: Thu Nov 07, 2013 5:50 pm
Location: Montreal

Re: TOC not expanding on load

Unread postby Tim Green » Mon Jul 25, 2016 8:47 am

Hi Ed,

Which skin are you using? If you are using a V3 Responsive skin you won't get this feature because it is not supported there. The new WebHelp 3 format does not support this for technical reasons. If you are using any other skin you just need to configure this setting in the skin and not in the project.

In the V3 skins a completely new way of generating the TOC is used to significantly reduce memory usage on mobile devices so that they can handle large TOCs more efficiently. Only the visible portions of the TOC actually exist as HTML. They are generated on the fly, and only when the user actually chooses to open a chapter, and they are deleted again as soon as the chapter is closed. No chapters are expanded automatically. When you are using these skins it is better to structure your TOC so that you have a basic structure of top-level chapters visible, rather than hiding everything inside one chapter. This is also generally the best way to structure a TOC. :)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19993
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: TOC not expanding on load

Unread postby Ed Hawco » Tue Jul 26, 2016 3:18 pm

Ah, I see. I am using a responsive skin, so that explains it.
e
d
============================================
Ed Hawco
User avatar
Ed Hawco
 
Posts: 137
Joined: Thu Nov 07, 2013 5:50 pm
Location: Montreal

Re: TOC not expanding on load

Unread postby Connie Cannon » Fri Jan 05, 2018 8:27 pm

Hi guys, I'm late to the party, but I'm having the opposite problem. I would like the unfocused entries to be collapsed, so I checked that box. They are collapsed when I first build it, but when I open index.html in the output folder they are expanded.
I am using a responsive skin...What do I have to do?

Thanks!
Connie
*post #1*
Connie Cannon
 
Posts: 5
Joined: Tue Nov 28, 2017 12:21 am

Re: TOC not expanding on load

Unread postby Connie Cannon » Fri Jan 05, 2018 8:44 pm

P.S.
I was using Chrome.
I tried it in Internet Explorer, and at first the behavior was the same; however, there was an error message that said: content was blocked, do I want to unblock content? I said yes, and it was fixed. :)
But this company is a Chrome shop...
Connie
Connie Cannon
 
Posts: 5
Joined: Tue Nov 28, 2017 12:21 am

Re: TOC not expanding on load

Unread postby Tim Green » Sun Jan 07, 2018 2:52 pm

Hi Connie,

This is happening because you are testing your WebHelp locally without a web server. Once it is online (either on the Internet or on your local intranet web server) it will work fine in Chrome, and you can also test locally in Chrome if Chrome is your default browser, so that the WebHelp opens in Chrome automatically after being generated by Help+Manual. Alternatively, you can let it open in your default browser and then copy the URL from the Address: field of that browser and then paste that into Chrome. Then it will work, because that uses the address of the mini web server that Help+Manual uses to open WebHelp automatically.

Actually, you will also find that Internet Explorer is affected as well: Users who open WebHelp locally without a web server with IE will have to click away an annoying yellow safety warning bar that cannot be disabled. This all has nothing to do with Help+Manual -- it is the same for all complex web pages opened locally.

Webhelp opened from a web server or on the Internet or an intranet is not affected. So if you are just testing locally and deploying on a server you will not have any problems with Chrome.

In Help+Manual we have implemented an integrated mini web server that is started automatically to display WebHelp when you display it automatically after publishing. This will then display in your default browser in the mini server and if that browser is Chrome it will work fine directly. If it is another browsers, you can then also test it in Chrome because the mini server will still be running. You just need to copy the 127.0.0.1... URL from the Address: bar of the default browser to the Address: bar in Chrome or any other browser to test there as well.

If you must open the help locally and without a web server in Chrome It is possible to work around it in a number of ways:

1: Use the new EWriter format supported by Help+Manual 7 instead. EWriter gives you all the benefits of WebHelp in a single file with its own integrated server and viewer. See here for details:

https://www.helpandmanual.com/help/inde ... writer.htm

2: Use the new V3 Responsive skins from the Premium Pack 3 add-on. These use new technologies that allow local use without a web server at all in all browsers. See here for details:

https://www.helpandmanual.com/products_hm_pluspack.html

However, there is an unfortunate caveat for this now: In their infinite wisdom (not), Microsoft have now decided to block ALL scripting without exception in the new Edge web browser included as the default with Windows 10. It doesn't matter any more what scripting you are using, in Edge nothing will work if the HTML pages are not on a web server. :evil:
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19993
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: TOC not expanding on load

Unread postby Connie Cannon » Wed Jan 17, 2018 7:28 pm

Thanks so much, Tim--I really appreciate your detailed explanation! :)
Connie Cannon
 
Posts: 5
Joined: Tue Nov 28, 2017 12:21 am

Re: TOC not expanding on load

Unread postby Connie Cannon » Thu Feb 08, 2018 12:59 am

Hi again,

When QA tested the Help, they complained that they had to double-click the chapter (w/o text) titles to view the child topics. You only have to click the book icon once to view the child topics, so why doesn't it extend across the whole entry? I went back and checked the "single click on caption..." box, but it didn't change anything locally. I'm using a responsive Webhelp skin, not from the premium pack...what can i do? Is there a hack?

Thanks,
Connie
Connie Cannon
 
Posts: 5
Joined: Tue Nov 28, 2017 12:21 am

Re: TOC not expanding on load

Unread postby Tim Green » Thu Feb 08, 2018 8:28 am

Connie Cannon wrote:When QA tested the Help, they complained that they had to double-click the chapter (w/o text) titles to view the child topics. You only have to click the book icon once to view the child topics, so why doesn't it extend across the whole entry? I went back and checked the "single click on caption..." box, but it didn't change anything locally. I'm using a responsive Webhelp skin, not from the premium pack...what can i do? Is there a hack?

The single-click option is the one you want, but you probably edited it in your project and not in the skin. You need to open the .hmskin file and edit the setting in the same place there instead. When you use a skin the internal HTML templates for topic pages and all the WebHelp pages and the WebHelp navigation settings are loaded from the skin and not from your project, so you need to make any changes there.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19993
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: TOC not expanding on load

Unread postby Connie Cannon » Thu Feb 08, 2018 6:23 pm

Yes, that worked--thank you so much, Tim! <3
Connie Cannon
 
Posts: 5
Joined: Tue Nov 28, 2017 12:21 am


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 2 guests