Search controls missing

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Search controls missing

Unread postby John Van Dyke » Mon Mar 27, 2017 9:43 pm

This is an odd one - I've searched the forums and haven't found an issue like this.

When WebHelp is rendered the Search controls (textbox, Submit button, results per page text and dropdown menu, and the Match radio button group are all missing. I have no idea how to solve this.

I've attached a screenshot.
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
John Van Dyke
 
Posts: 8
Joined: Mon Mar 27, 2017 5:01 pm

Re: Search controls missing

Unread postby Tim Green » Tue Mar 28, 2017 7:46 am

Hi John,

It looks like you're just using the standard integrated templates in your project without a skin. My guess is that your project is old and was created in an earlier version of HM, and its templates are not compatible with the output generated by the current version.

The simplest solution is just to click on the Select Skin bar in the Publish screen and choose one of the standard skins provided with Help+Manual. When you publish, this will use the new templates and settings in the skin instead of the old ones in your project.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19534
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Search controls missing

Unread postby John Van Dyke » Tue Mar 28, 2017 3:08 pm

Thanks for the quick reply. For background, this is brand new project built in HM7.

We did not use a skin so I tried your suggestion by publishing again, this time with the 2 frames classic blue. As a test, I opened the index.html to see if adding the skin would produce the search controls. Still none showing.
John Van Dyke
 
Posts: 8
Joined: Mon Mar 27, 2017 5:01 pm

Re: Search controls missing

Unread postby Tim Green » Wed Mar 29, 2017 7:12 am

Hi John,

Please don't use the old classic skins. They are really only for legacy customers who are still using very old and obsolete versions of Internet Explorer. Choose one of the skins with the words "integrated" or "responsive" in their names.

If you continue to have problems the issue may be that support for JavaScript is disabled in your browser.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19534
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Search controls missing

Unread postby John Van Dyke » Wed Mar 29, 2017 3:41 pm

Thanks for the info on the legacy vs new skins. I verified that javascript is enabled; I tested with both IE11 and Chrome. Based on your reply I published again, this time with the iFrames Responsive blue.

Same results - search controls are missing.
John Van Dyke
 
Posts: 8
Joined: Mon Mar 27, 2017 5:01 pm

Re: Search controls missing

Unread postby Tim Green » Thu Mar 30, 2017 8:30 am

John Van Dyke wrote:Same results - search controls are missing.

If everything you say is correct that should be physically impossible. Please mail me your project at support AT ec-software.com (replace the AT with @) and I will test it directly.

Before you do this, however, please reinstall Help+Manual with the current installer, which you can download here:

http://www.helpandmanual.com/downloads.html?upd

Just install on top of your current version. This won't change any settings etc. Then restart Windows before trying again (just covering all the bases here). If you still have the same problem, mail me your project. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19534
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Search controls missing

Unread postby John Van Dyke » Fri Mar 31, 2017 2:31 pm

I hope it is physically impossible and that I'm missing something simple. I can email the hmxp file but we are using a server license, so the reinstall is something that's out of my hands.
John Van Dyke
 
Posts: 8
Joined: Mon Mar 27, 2017 5:01 pm

Re: Search controls missing

Unread postby Tim Green » Sat Apr 01, 2017 9:48 am

Hi John,

Please look in Help > About Help+Manual in the Ribbon toolbar. What are the version and build number displayed there?
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19534
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Search controls missing

Unread postby John Van Dyke » Tue Apr 18, 2017 7:01 pm

Tim Green wrote:Hi John,

Please look in Help > About Help+Manual in the Ribbon toolbar. What are the version and build number displayed there?


Sorry for the delay in replying.

Server Edition Version 7.1.0, Build 3925.
John Van Dyke
 
Posts: 8
Joined: Mon Mar 27, 2017 5:01 pm

Re: Search controls missing

Unread postby Tim Green » Wed Apr 19, 2017 9:18 am

John Van Dyke wrote:Sorry for the delay in replying.
Server Edition Version 7.1.0, Build 3925.

That is out of date by quite a long time. Please download the current installer here and update by installing on top of your current version:

http://www.helpandmanual.com/downloads.html?upd

This will not change any settings etc.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19534
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Search controls missing

Unread postby John Van Dyke » Wed Apr 26, 2017 10:00 pm

Thanks for the link. Our server folks pulled and installed the updates, but the issue remains.

After the updates were installed I tried publishing from our share location to a folder on the share drive, and then to a folder on my machine. I then copied the source files/folders to my machine and published again (local and share locations).

It's still a mystery.
John Van Dyke
 
Posts: 8
Joined: Mon Mar 27, 2017 5:01 pm

Re: Search controls missing

Unread postby Tim Green » Thu Apr 27, 2017 7:47 am

Hi John,

Visit your WebHelp site, then press F12 to display the developer console in your browser. Make sure that the "console" option or tab is selected so that you can see JavaScript error messages. Press F5 to reload the page and then access the search page. You will almost certainly see some error messages in the console. Please post a screenshot of that.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19534
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Search controls missing

Unread postby John Van Dyke » Thu Apr 27, 2017 4:00 pm

as requested:

Dev tools output.png
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
John Van Dyke
 
Posts: 8
Joined: Mon Mar 27, 2017 5:01 pm

Re: Search controls missing

Unread postby Tim Green » Thu Apr 27, 2017 5:19 pm

Hi John,

It looks as though the skin you are using is damaged. The search is not being displayed because of errors in the search scripts that should not normally occur. Please mail a small demo project in single-file .hmxz format and the .hmskin file you are using to support AT ec-software.com (replace the AT with @) and we will check them for you.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19534
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Search controls missing

Unread postby John Van Dyke » Fri Apr 28, 2017 2:53 pm

The hmxz file has been sent. Please note - we are not using skins with this project, hence there's not a skin file with the email.
John Van Dyke
 
Posts: 8
Joined: Mon Mar 27, 2017 5:01 pm


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron