Puzzle - Project Explorer <> Editor

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Puzzle - Project Explorer <> Editor

Unread postby Dave Gehman » Thu Oct 05, 2017 11:08 pm

I have two TOC (Project Explorer) entries that behave differently when edited.

When I edit TOC "1.2 How It Works", the edit is automatically applied to the Editor.
Before:
Image

After
Image
NOTE that the edit has propagated to the Editor.

When I edit TOC "1.3 Quick Examples..." , the edit is not propagated to the Editor.
Before:
Image

After:
Image
NOTE that the edit has NOT propagated to the Editor

As far as I can see in the properties for the headings, they are the same type with the same settings. What am I doing wrong?
Dave Gehman
 
Posts: 24
Joined: Sat Sep 23, 2017 9:05 pm

Re: Puzzle - Project Explorer <> Editor

Unread postby Tim Green » Fri Oct 06, 2017 7:39 am

Hi Dave,

You're not doing anything wrong. It's a feature: Basically, it is based on the observation that sometimes you want a longer title in the topic header than in the TOC caption. The text in the TOC caption is dynamically linked to the header, but only as long as the two texts are identical. Then when you edit the TOC caption the topic header is changed automatically, along with the <title> tag text in the Topic Options tab. But if you edit the topic header directly it will NOT update the TOC caption, because then it is assumed you want a different text there. And once the texts are different, changing the TOC caption will no longer change the header text.

To reset this you just need to make the caption and header texts identical again. After that, editing the TOC caption will once again update the header text as well. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19412
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Puzzle - Project Explorer <> Editor

Unread postby Dave Gehman » Fri Oct 06, 2017 11:42 am

But if you edit the topic header directly it will NOT update the TOC caption, because then it is assumed you want a different text there. And once the texts are different, changing the TOC caption will no longer change the header text.


I fear that the puzzle remains.

My workflow was just the opposite. I edited the the original TOC caption for 1.3. That is, I didn't edit the topic header.

After editing the TOC caption for 1.3, the topic header did not change as a result of that edit -- where the topic header DID change after editing the TOC caption in the topic just above (originally 1.2).
Dave Gehman
 
Posts: 24
Joined: Sat Sep 23, 2017 9:05 pm

Re: Puzzle - Project Explorer <> Editor

Unread postby Tim Green » Fri Oct 06, 2017 2:42 pm

Dave Gehman wrote:I fear that the puzzle remains.

No, it doesn't. I can't see all the text but if that happens it simply means that the caption and the header were not identical when you started editing. The header will only be updated if it was identical to the caption before you started editing. In your case, including the numbers.

By the way: Entering numbering manually in the TOC is a very bad idea that you will regret quite soon. Where it is needed numbering can be generated automatically when you publish. For example in PDF and DOCX it is generated by the external templates, and if you have numbering entered manually you will get both the template numbering and yours. You can also generate numbering automatically in the TOC in WebHelp, but not in CHM.

Apart from the other problems, if you enter numbering manually you will have to edit everything, manually, if you ever decide you need to move a topic somewhere else... 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19412
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Puzzle - Project Explorer <> Editor

Unread postby Dave Gehman » Fri Oct 06, 2017 2:55 pm

OK.

Re: template-created numbering. Is this something I need to code in a template file?

The last time I did manual HTML was 19 years ago and I know nothing of XML... so custom programming is a bit scary.

If it's built into all the Premium Pack WebHelp templates, then I can relax.
Dave Gehman
 
Posts: 24
Joined: Sat Sep 23, 2017 9:05 pm

Re: Puzzle - Project Explorer <> Editor

Unread postby Tim Green » Sat Oct 07, 2017 8:28 am

Dave Gehman wrote:Re: template-created numbering. Is this something I need to code in a template file?

No, not at all. In WebHelp you don't need to do anything in a template at all. The numbering is just a setting you can turn on and off and configure in your project (if you're not using a skin) or in the .hmskin project (if you are). It is in Configuration > Publishing Options > WebHelp > Navigation:

http://www.helpandmanual.com/help/index ... gation.htm

Note that this will only number the table of contents, not the headings in your topics.

In PDF there is a similar and slightly more extensive feature that you can set up in the PDF template in the Manual Designer program. Detailed instructions are included in that program's help displayed with F1 once you are running it.

If it's built into all the Premium Pack WebHelp templates, then I can relax.

Numbering in the TOC isn't a PP feature, it's available for any WebHelp output with the setting referenced above. :)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19412
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Puzzle - Project Explorer <> Editor

Unread postby Dave Gehman » Sat Oct 07, 2017 1:13 pm

Thanks.

A bit of confusion. I understant that I have to edit the .hmskin file that controls my WebHelp output, if I want sequential automated numbering. No problem with that.

However, the H+M help file says that "To edit a skin, make a copy of the .hmskin skin file in your project folder...."

There are no .hmskin files in my project folder, which is found at This PC > Documents > HelpAndManual Projects.

There *are* a bunch of hmskins in C:/Program Files (x86) > EC Software > HelpAndManual7 > Templates > HTML Skins.

Am I right in thinking that I need to copy and edit the skin that resides in the Program Files >... >Templates > HTML Skins location?

If so, should I place the copy in my projects folder?

If the copy should remain in the HTML Skins folder*, do I rename the original something like "[name of skin].old" and keep the original name for the now-copied and now-modified .hmskin? (That is, are the actual file names important, as they are in Windows system DLLs?)

*I'm guessing it should be placed in HTML SKins -- otherwise H+M won't find it at the time of compiling/publishing... unless you have cleverly done an implementation routine in which H+M looks first for an hmskin in Projects, and if not found, then in HTML Skins.
Dave Gehman
 
Posts: 24
Joined: Sat Sep 23, 2017 9:05 pm

Re: Puzzle - Project Explorer <> Editor

Unread postby Martin Wynne » Sat Oct 07, 2017 1:34 pm

Dave Gehman wrote:However, the H+M help file says that "To edit a skin, make a copy of the .hmskin skin file in your project folder...."

Hi Dave,

Tim meant "make a copy of the required .hmskin skin file from Program Files into your project folder".

It doesn't have to be in the project folder if you want to put it somewhere else (for example to use it again in other projects).

Then edit the copy if necessary, not the original. To edit it, open it in H&M as if it is a project (if it is not a Premium Pack skin). If it is a Premium Pack skin, edit it with Premium Pack Toolbox program.

To use it for your project, navigate to and select it in the Publishing dialog.

p.s. you don't need a skin to get automated nested topic numbering. Native H&M can do that without using any skin.

regards,

Martin.
Last edited by Martin Wynne on Sat Oct 07, 2017 1:40 pm, edited 1 time in total.
User avatar
Martin Wynne
 
Posts: 2191
Joined: Mon May 12, 2003 3:21 pm
Location: West of the Severn, UK

Re: Puzzle - Project Explorer <> Editor

Unread postby Dave Gehman » Sat Oct 07, 2017 1:37 pm

All is revealed. Thanks, Martin.

Dave
Dave Gehman
 
Posts: 24
Joined: Sat Sep 23, 2017 9:05 pm

Re: Puzzle - Project Explorer <> Editor

Unread postby Dave Gehman » Sat Oct 07, 2017 2:07 pm

OK - I've placed the modified hmskin in my Projects folder.

However, in the File > Publish options, I can't find a way to direct H+M to use the modified skin. The "Select Skin" option sends me only to the main repository under Program FIles (x86) > EC Software > HelpAndManual7 > Template...

IOW, I can't find a way to browse to the changed hmskin in my Projects folder. I looked through all the program and project options, thinking I could add to the list of folders for specifying hmskins, but didn't find anything.

I'm going to try to rename the modified hmskin and throw it back into the original Templates folder...

[EDIT] Success after placing the modified (and re-named) hmskin into the original folder! Thanks, all.
Dave Gehman
 
Posts: 24
Joined: Sat Sep 23, 2017 9:05 pm

Re: Puzzle - Project Explorer <> Editor

Unread postby Martin Wynne » Sat Oct 07, 2017 3:15 pm

Dave Gehman wrote:[EDIT] Success after placing the modified (and re-named) hmskin into the original folder! Thanks, all.

Hi Dave,

Don't do that if you value your sanity. It might disappear in a program upgrade. Put it back in your project folder, or somewhere else if you prefer.

Scroll to the bottom of the skin drop-down in the Publish dialog, and click Open Skin..., see:

open_skin.png

I'm glad I'm not the only one who finds some of the H&M user interface a puzzle at times. But I've been using it for only 14 years. :)

Martin.
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
User avatar
Martin Wynne
 
Posts: 2191
Joined: Mon May 12, 2003 3:21 pm
Location: West of the Severn, UK

Re: Puzzle - Project Explorer <> Editor

Unread postby Dave Gehman » Sat Oct 07, 2017 5:40 pm

Again, thanks...

That option was way too small and light for my eyes to pick up. I never would have seen it if you hadn't pointed it out. I would much prefer something Windows-y, like seeing that option with a right-click on the Select Skin drop-down or the popping up of an Open dialog box...

But even if the UI has challenges, even with a few days' work, H+M is clearly miles ahead of Framemaker's UI (the setting for my last project, an update to documentation that went through revisions and updates for 8 years across multiple version releases of FM).

There were some key things that needed to be changed, but turned out to be unreachable -- that is, proved incapable of reverse engineering -- despite tens of hours of GoToMeetings with the original writers. Several features had two completely different pods (Adobe's god-awful chunks of UI) -- and many formatting options required opening three or more pods. :evil:
Dave Gehman
 
Posts: 24
Joined: Sat Sep 23, 2017 9:05 pm


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 3 guests