CHM & HTML output different using same skin

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

CHM & HTML output different using same skin

Unread postby Chris Latimer » Mon Nov 13, 2017 10:00 pm

Hi - The modified skin that publishes nicely to html doesn't look the same when published to chm. Specifically, I modified Webhelp, Integrated IFrames Blue Header skin to use a new banner image. But when I use that skin to publish to chm, the banner is not included, and the TOC open/closed book icons show as ? marks. Is there a Configuration setting I'm missing, or am I abusing the skin? Sorry for the newbie question, but this is my first attempt to publish to chm. Thanks very much.
Chris Latimer
 
Posts: 2
Joined: Tue Aug 29, 2017 2:38 pm

Re: CHM & HTML output different using same skin

Unread postby Martin Wynne » Mon Nov 13, 2017 11:46 pm

Hi Chris,

CHM is a 20-year-old Microsoft format which hasn't been upgraded since it was first released. It contains known bugs, and very limited scope for customizing the appearance. Publishing to CHM with a Webhelp skin is asking for grief. There are some CHM-specific skins available.

You might like to look at H&M's EWriter format, which provides a modern alternative to CHM with extra features.

regards,

Martin.
User avatar
Martin Wynne
 
Posts: 2232
Joined: Mon May 12, 2003 3:21 pm
Location: West of the Severn, UK

Re: CHM & HTML output different using same skin

Unread postby Tim Green » Tue Nov 14, 2017 11:16 am

Hi Chris,

Further to Martin's comments: Even though some WebHelp skins can be used for CHM, they can only style the topic box, nothing else. The CHM viewer is a Microsoft component and an integral part of Windows. Its appearance cannot be changed by a skin. It always looks the same. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19490
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: CHM & HTML output different using same skin

Unread postby Chris Latimer » Tue Nov 14, 2017 4:56 pm

[img]
ThanksMartinTim.jpg
[/img]
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
Chris Latimer
 
Posts: 2
Joined: Tue Aug 29, 2017 2:38 pm

Re: CHM & HTML output different using same skin

Unread postby Tim Green » Wed Nov 15, 2017 7:51 am

You're welcome!

As Martin suggested, do try EWriter. It has a lot of benefits for local help:

https://helpandmanual.com/help/index.ht ... writer.htm
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19490
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 1 guest