html tag not generated the same way using the same files

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

html tag not generated the same way using the same files

Unread postby Philippe » Fri Jan 12, 2018 3:41 pm

Hi !

I am automating the build of our online help using Jenkins, I have successfully generated the online help, but the generated files are not identical for some reason.

They are generated using the Command Line.

Inside the .htm files, the paragraph tag has " class="p_Normal" " added to it, so instead of being <p>&nbsp</p>, it's <p class="p_Normal">&nbsp</p>.

We are trying to find what could be causing this. On one build machine, it's generated with the extra stuff, and on the other without. Both use the same version of Help and Manual.

I am completely unfamilliar with Help and Manual, so any help is welcome.

Thanks !
Philippe
 
Posts: 7
Joined: Tue Nov 21, 2017 5:38 pm

Re: html tag not generated the same way using the same files

Unread postby Tim Green » Fri Jan 12, 2018 4:13 pm

Philippe wrote:Inside the .htm files, the paragraph tag has " class="p_Normal" " added to it, so instead of being <p>&nbsp</p>, it's <p class="p_Normal">&nbsp</p>

This is correct and required. If you look at the other machine where you are just getting the plain <p> tag you will find that the copy of Help+Manual there has an older version and build number (look in Help > About) and you should update it because it is important everyone should be working with the same version.

The reason for this is simple: A WebHelp page does not only contain content from the topic editor. It also contains a lot of other HTML, and it may contain other paragraph tags as part of the layout. In the past when we used classless <p> tags for the standard paragraphs formatted with the Normal style this created all kinds of strange errors in other paragraphs that were part of the page layout, because the CSS settings were affecting all the paragraphs in the same way, and that was not always desirable. In addition to that, you also got problems on responsive pages using ems/rems as the dimensions. If you then changed the base font, the classless <p> tags would create incorrect font sizes due to nesting effects. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19880
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: html tag not generated the same way using the same files

Unread postby Philippe » Fri Jan 12, 2018 4:59 pm

We are in fact using the same version of Help and Manual on both machines : 7.2.0 Build 4035.

Could it be something in the options ? A different configuration somewhere ?
Philippe
 
Posts: 7
Joined: Tue Nov 21, 2017 5:38 pm

Re: html tag not generated the same way using the same files

Unread postby Tim Green » Fri Jan 12, 2018 5:06 pm

Philippe wrote:We are in fact using the same version of Help and Manual on both machines : 7.2.0 Build 4035.

Then you're using an obsolete, unsupported version anyway. Please update to the current 7.3.4 right away:

https://www.helpandmanual.com/downloads.html?upd
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19880
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 2 guests