Error when publishing as PDF

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Error when publishing as PDF

Unread postby Kif Taco » Tue Feb 20, 2018 1:53 pm

Hello Tim,

When I tried to publish my project as PDF, it showed me the following error:

Error when completing print page 525: Stream write error

What does it mean? I can't open the file to see what is on page 525 as it is not generated at all. It happens every time I try to publish the project. I tried to publish it also as webhelp and it worked with no issues.

Thank you in advance,
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
Kif Taco
 
Posts: 13
Joined: Thu Feb 23, 2017 9:54 am

Re: Error when publishing as PDF

Unread postby Tim Green » Tue Feb 20, 2018 3:37 pm

Hi Kif,

This error usually occurs when your local disk is full and Help & Manual cannot write the temporary files for the PDF (which may be rather big, sometimes several MB per page). Check free space on your disk and make some free. :)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Error when publishing as PDF

Unread postby Kif Taco » Wed Feb 21, 2018 8:19 am

Hi Tim,

Thanks for the answer. I know that there was an old post in this forum about this and in that particular case it was caused by a full disk. But in my case there is more that 17GB of free space on the disk. I will ask our administrator but meanwhile, do you have any other ideas?

*EDIT*

The issue seems to be caused by an unusually large template. We are trying to investigate what causes the template to be 100MB+. It is definitely not the size of the images used in the PDF template. Any ideas what can cause this?

Regards,
Kif Taco
 
Posts: 13
Joined: Thu Feb 23, 2017 9:54 am

Re: Error when publishing as PDF

Unread postby Tim Green » Wed Feb 21, 2018 12:22 pm

Hi Kif,

Do you get the same error if you use a different template? Try with one of the standard PDF templates supplied with Help+Manual. The most likely culprit in this case is one of the images in the template. You can try making a backup of it and taking the images out one by one and re-publishing until you find the culprit. If the template is 100MB the images are possibly also larger than they need to be for most PDF applications.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Error when publishing as PDF

Unread postby Kif Taco » Thu Feb 22, 2018 1:34 pm

Hi Tim,

yes it worked with the standard templates. But it is very strange:

The images we used in the template were small company logo (6x), front page cover and last page cover. All the images were PNG with 300 DPI. These 8 images had only about 2 MBs. But when we tried to reduce the quality to 200 DPI the size of the template dropped by 30 MBs! And then it worked. We tired it with JPG images with the same results.

This behavior is pretty odd but for us the case is closed.

Thanks again for your assistance.
Kif Taco
 
Posts: 13
Joined: Thu Feb 23, 2017 9:54 am

Re: Error when publishing as PDF

Unread postby Tim Green » Thu Feb 22, 2018 2:49 pm

Kif Taco wrote:The images we used in the template were small company logo (6x), front page cover and last page cover. All the images were PNG with 300 DPI. These 8 images had only about 2 MBs. But when we tried to reduce the quality to 200 DPI the size of the template dropped by 30 MBs! And then it worked. We tired it with JPG images with the same results.


It is possible that your template contains other images that you can't see because they have been shifted outside the visible area. To check this, look in the Edit > Select Object menu in each section of the template. This lists all the objects in the section, both visible and invisible. If you find an image you can't see, select it with this menu and then you can move it into view with the keyboard arrow keys.

If you don't find anything there it would be very helpful if you could let us have a look at your original, oversized template, because if you only have 2MB of images and are getting a 100MB template file then something is wrong. If it's small enough to mail when you pack it in a zip, mail it to support AT ec-software.com (replace the AT with @) . Otherwise you could mail us a download link.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 15 guests

cron