PDF - Japanese font, English font - don't play well together

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

PDF - Japanese font, English font - don't play well together

Unread postby Dave Gehman » Tue Mar 13, 2018 5:36 am

We're looking for a solution to problems in the PDF output of the Japanese translation of our help file. (WinHelp output works fine, with none of the issues below.)

PDF manual template: Classic_manual.mnl

Font mode: embed TrueType fonts

The font is Segoe UI* (selected by Tokyo-based translator).

We're getting overlapping and mis-alignment in the PDF output of our Japanese translation where both English and Japanese appear on the same line. Plus, there are issues with toggled content (light blue-green background). Excerpt:

Image

Where English words appear in the same line as Japanese in the text, the English content drops ~12-14 points (printer's measure) / ~5/16 in [~10mm] (physical measure) below the Japanese line and superimposes itself over the next line of Japanese.

In toggled text, only the bottom 1/8 or less of the first line of toggled content is visible.

_____________________________________
* Segoe UI does not appear in Wikipedia's "List of CJK [Chiniese/Japanese/Korean] Fonts"
Dave Gehman
 
Posts: 282
Joined: Sat Sep 23, 2017 9:05 pm

Re: PDF - Japanese font, English font - don't play well toge

Unread postby Tim Green » Tue Mar 13, 2018 8:02 am

Hi Dave,

There have been some issues with spacing in the new PDF engine that are being worked on. Please try the current interim version of 7.3.5 to see if this helps:

https://www.helpandmanual.com/download/ ... p-v735.exe

This being said, there are also frequent problems with mixing Asian and Latin text on the same page, more when they are mixed in the same paragraphs. When you are using the same font for both languages it's essential that you use a full Unicode font that includes all the characters used for both languages. If even a single character is not available in the font, Windows replaces the entire font with an alternative or even graphic glyphs, and the results can be very odd.

Another thing to check is the font embedding. Many issues in Asian PDFs can be dealt with by changing the font embedding setting to either CID Fonts, or Type 3 Fonts. Try CID first, because that will provide slightly crisper text and if it works it is a better option.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20370
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: PDF - Japanese font, English font - don't play well toge

Unread postby Dave Gehman » Tue Mar 13, 2018 12:07 pm

Tim Green wrote:Please try the current interim version of 7.3.5 to see if this helps:


If I install on a virtual machine, will I be able to license/activate it? Or can you say more or less confidently that 7.3.5 is bug-free, and will be a problem-free upgrade -- or that it's possible to move back to our current 7.3.4?

That last sounds like an impertinent question, but smooth H+M running (and it has been a remarkably bug-free run for us) is important for various reasons right now.

Another thing to check is the font embedding. Many issues in Asian PDFs can be dealt with by changing the font embedding setting to either CID Fonts, or Type 3 Fonts. Try CID first, because that will provide slightly crisper text and if it works it is a better option.


I'll try these options first, before installing 7.3.5.
Dave Gehman
 
Posts: 282
Joined: Sat Sep 23, 2017 9:05 pm

Re: PDF - Japanese font, English font - don't play well toge

Unread postby Dave Gehman » Tue Mar 13, 2018 12:14 pm

Ignore impertinent questions -

Embedding as Type 3 worked! :hoorahg:
Dave Gehman
 
Posts: 282
Joined: Sat Sep 23, 2017 9:05 pm

Re: PDF - Japanese font, English font - don't play well toge

Unread postby Tim Green » Tue Mar 13, 2018 5:58 pm

Hi Dave,

Good to hear it worked. Installing our released betas should always be pretty much trouble-free (I don't work with anything else) and you can always return to the previous version. All you need to do is reinstall the release version "on top". Help+Manual is very robust as far as that goes -- even if you were to go and delete ALL its Windows Registry entries it would simply shrug its shoulders and re-build them the next time it starts. 8)

However, it would be very helpful for us if you could also confirm that the current beta also solves the problem with your Latin + Japanese combination. You can install on a VM to do that if you want. It will run in fully functional free trial mode if you don't register. You will get a copyright notice and some scrambled words in the PDF output, but you should still be able to test your issue.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20370
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: PDF - Japanese font, English font - don't play well toge

Unread postby Dave Gehman » Tue Mar 13, 2018 6:52 pm

Sure. I can't do it today as we're in a major blizzard and likely to lose electrical power.

I'll tackle this as soon as consistent power is available.

I assume that I should use 'embed as trutype font' ? Any other settings or configurations that I should be using?
Dave Gehman
 
Posts: 282
Joined: Sat Sep 23, 2017 9:05 pm

Re: PDF - Japanese font, English font - don't play well toge

Unread postby Tim Green » Wed Mar 14, 2018 9:13 am

Dave Gehman wrote:I assume that I should use 'embed as trutype font' ? Any other settings or configurations that I should be using?

That's the only thing that's really important. Thanks a lot!
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20370
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: PDF - Japanese font, English font - don't play well toge

Unread postby Dave Gehman » Wed Mar 14, 2018 2:24 pm

Sorry, no change.

Downloaded & installed 7.3.5. (Double-checked after getting the negative result - it really was 7.3.5).

Ran our project as PDF with TrueType embedded.

Font is still Segoe UI, 11 point (body text/normal)

Got the original result - the English text baseline drops significantly below the Japanese, and the first line of text in toggles is truncated:
Image
Dave Gehman
 
Posts: 282
Joined: Sat Sep 23, 2017 9:05 pm

Re: PDF - Japanese font, English font - don't play well toge

Unread postby Tim Green » Wed Mar 14, 2018 5:44 pm

Hi Dave,

Thanks. It would be helpful if you could mail a small demo project illustrating this to support AT ec-software.com (replace the AT with @). We only need a .hmxz project file with a couple of affected topics for this, no other files.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20370
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: Bing [Bot] and 5 guests

cron