Unable to launch program when working remotely

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Unable to launch program when working remotely

Unread postby Chris Campbell » Wed May 30, 2018 5:04 pm

I hope someone can help. I've been using H&M for years. I normally work in an office, and our source help file and images and all associated files are on a shared network drive.

I copied those files to my local machine so I could work on them remotely. I assumed I should be able to open them normally and then copy them back over when I returned. However, I am unable to launch the program. When I attempt to open launch I get the H&M splash window and it just hangs.

Please help.

Chris
Chris Campbell
 
Posts: 15
Joined: Mon Oct 31, 2011 3:03 pm

Re: Unable to launch program when working remotely

Unread postby Tim Green » Wed May 30, 2018 5:11 pm

Hi Chris,

When you say "work remotely" do you mean that you have put the files onto the machine that you are working on at home and are working there, or are you working via a network connection? If the former, you need to download and run the Help+Manual installer, not just copy its directory. You can get it here (run it on top of your office version as well to make sure you're up to date there as well):

https://www.helpandmanual.com/downloads.html

If you are trying to run Help+Manual remotely it is a different situation. You need a server license for that, and you should also only do that on a local network. Trying to actually run the program via an Internet connection or a VPN won't work, and even if it does it would be excruciatingly slow and horribly unreliable: As soon as you have a small network error you would lose the connection and your project could be corrupted. The only safe way to work remotely is to log in to the remote machine (for example your office machine) via Remote Desktop. Then it is running in the remote location and you are effectively only connected via very long keyboard, mouse and monitor cables. And unlike actually running the program over the network, nothing bad can happen if you lose the connection.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20079
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Unable to launch program when working remotely

Unread postby Chris Campbell » Wed May 30, 2018 5:14 pm

Tim,

The program is installed on my local machine. Only the hmxz file and associated baggage, graphics, skins, topics, etc are on the network drive. I copied all of that to my local machine to work from home.
Chris Campbell
 
Posts: 15
Joined: Mon Oct 31, 2011 3:03 pm

Re: Unable to launch program when working remotely

Unread postby Tim Green » Wed May 30, 2018 5:20 pm

Chris Campbell wrote:The program is installed on my local machine. Only the hmxz file and associated baggage, graphics, skins, topics, etc are on the network drive. I copied all of that to my local machine to work from home.

If you're running it locally and it's hanging on start something is just wrong with the installation. Do a clean install with the current installer:

1: Uninstall Help & Manual in the Windows Control Panel (Add/Remove Programs)

2: In the Windows Start menu select Run and enter "regedit" to start the Registry Editor. Go to HKEY_CURRENT_USER > Software > ECSOFTWARE. Select the "Help & Manual 7" key (folder) and press DELETE to delete it.

3: Download the latest version of Help & Manual from our website:

https://www.helpandmanual.com/downloads.html?upd

4: Install the program with the new installer.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20079
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Unable to launch program when working remotely

Unread postby Chris Campbell » Wed May 30, 2018 5:22 pm

It works perfectly when I'm in the office, but I can try reinstalling.

Is this going to require me to reinstall and set up the premium pack as well? I hope not. :\
Chris Campbell
 
Posts: 15
Joined: Mon Oct 31, 2011 3:03 pm

Re: Unable to launch program when working remotely

Unread postby Tim Green » Thu May 31, 2018 7:49 am

Chris Campbell wrote:It works perfectly when I'm in the office, but I can try reinstalling.

Are you saying that it's not running on the same computer when you're not in the office?

I'm afraid what you have done and are doing here is still not clear from your descriptions. Please describe how you installed the program and the projects you want to edit on the computer on which you are having problems.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20079
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Unable to launch program when working remotely

Unread postby Chris Campbell » Fri Jun 01, 2018 3:13 pm

Hi Tim,

First - thanks for your excellent support. You always reply quickly any time I have a question! :)

The program eventually launched, unexpectedly, after a very long time. I thought it was hanging, but apparently it was just extremely slow to load everything. I'm not sure why it had such an issue, because it's normally reasonable snappy when loading the same files from the network. Anyway, I was able to continue working.

For your info, my only personal machine is a laptop - it's the same machine I use at work or remotely. The H&M program is installed locally on this machine. We have several individual licenses of H&M in the office, and they are all installed locally on the users' machines. The help file and all of its associated files (topics, baggage, images, etc) are all sitting on a shared network drive. Any author that needs to edit launches the program on their machine but they're opening the source file from the network. We're operating in shared file mode, where the topics are locked if anyone is editing. However, in reality I'm typically the only author and I own the process and am the "expert" in the tool in our office.

What I was trying to do yesterday was copy all of the network files to a folder on my machine to take home, then launch the program and open the local copy. I planned to edit, then copy those files back onto the network later.

Hope this helps. Thanks again for your excellent support.

Chris
Chris Campbell
 
Posts: 15
Joined: Mon Oct 31, 2011 3:03 pm

Re: Unable to launch program when working remotely

Unread postby Tim Green » Sat Jun 02, 2018 11:31 am

Hi Chris,

Help & Manual is normally very responsive. However, there are some correctable factors that can slow it down under certain circumstances. I include my text covering all the bases below, but in your case the culprit will almost certainly be network references to unavailable destinations in your project that Windows is being agonizingly slow at trying to resolve. Unfortunately, Windows is terrible at handling this situation and often seems to be doing nothing for extended periods of time while trying to figure out whether the location is there or not.

By the way: If you need to work on your projects out of office frequently, setting up a free SubVersion server is by far the best solution. Then you no longer need to copy anything back and forth, and you also no longer need to work on slower network drives at all. Instead, you always work on a local working copy of the project that is linked to the master copy on the server. You only need to contact the server before work to get any pending changes made by others, and after work to update the master with your own changes. See here for details:

https://www.helpandmanual.com/help/inde ... ed_vcs.htm


Possible reasons for slow performance in Help+Manual:

* Orphaned network references to your project referencing locations on the network that no longer exist.
* Network performance if you are storing large projects on a network drive/share and working there
* Use of a large number of embedded images in your project.
* Integration of your project in a Subversion repository incorrectly using network locations for the working copies of your project.

First, please check that you are using the current version of Help & Manual. The current version of Help & Manual 7 is 7.3.5 Build 4434. Check your version with Help > About Help & Manual. If you need to update you can download the current installer here (just install on top of your current version to update):

https://www.helpandmanual.com/downloads.html?upd

1) Orphaned network references

Slow loading and saving performance is often caused by orphaned network references in your project to locations on the network that no longer exist, and it may be made worse by embedded images in your project, which can also slow down editing.

Windows networks take a very long time to resolve invalid network references. In your project go to the following locations and delete any references to network locations that are no longer valid:

* Project Explorer > Configuration > Common Properties > Project Search Path
* Project Explorer > Configuration > Common Properties > Help Windows: HTML Help Options
* File > Recent projects (delete any projects shown in red that no longer exist)

2) Network performance

If you are storing your projects on a network drive or share it is possible that the network itself may be the bottleneck. To test this, try making a copy of your project on your local machine and edit it there for a while to see if you get better performance. Use Save As... in the Help & Manual File menu to save the copy, and save it in a folder in your own Documents directory on your local computer. Using the Documents directory ensures that you won't have Windows account permissions problems, because you always have full read and write permissions there.

3) Embedded images

When you copy and paste images from another program like Word they are initially embedded in your project. If you have more than just a couple of these images they can inflate the size of your project and will eventually slow down editing because embedded images use up very large amounts of memory and computer resources (many times their own uncompressed size). You need to convert embedded images to external files:

1. Click on an image in the Help & Manual editor. If it turns "negative" when you select it, it is OK. If it does not, it is embedded.
2. Right-click on the embedded image and select the option to convert it to an external file.
3. Repeat this for all embedded images in your project.

You can also locate embedded images with the Project Report tool in the Project tab. Run a full report with image references and search for the word "embedded" in the report. That will show you which topics contain embedded images.

4) Incorrect configuration of Subversion version control integration

Subversion version control works very differently from normal multi-user editing. In normal multi-user, everyone works on the same copy of the project on a network drive accessed by all users. You cannot and should not use this paradigm with Subversion, and if you do you will get a truly massive slowdown in performance, making editing pretty much impossible. You will also get a serious degradation of performance if each user tries to put their Subversion working copy of the project on a network drive instead of locally.

When working with Subversion, every user must work on their own local, linked copy of the project. This copy must be stored on a local drive on the computer they are working on, NOT on a network drive. This is crucial for Subversion to work properly. Otherwise you have geometrically expanding loopback references through the network, slowing editing to a crawl.

You can find full instructions for setting up Subversion correctly in this chapter in the HM help:

More Advanced Procedures > Using Version Control Systems
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20079
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 3 guests