Find (search) anomaly

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Find (search) anomaly

Unread postby Dave Gehman » Fri Jun 15, 2018 10:04 am

When I begin a search of All Topics from Here topics for "chrome," I get no hits. The "here" is the first topic under Table of Contents, i.e., the first topic with words I have added rather than system-generated.

Image

When I restrict the search to a page where "chrome" exists, Find finds it:

Image

What might cause this anomaly? The fact that "chrome" is in a bulleted list?
Dave Gehman
 
Posts: 275
Joined: Sat Sep 23, 2017 9:05 pm

Re: Find (search) anomaly

Unread postby Tim Green » Fri Jun 15, 2018 12:24 pm

Hi Dave,

I just double-checked this and it appears to be working fine. One important thing to understand is that the search in both Current Topic and All Topics from Here always starts at the current cursor position in the current topic. So if your cursor position is after the search term, it won't be found. What may have happened is that the first time you searched the cursor was positioned after the search term, and the second time you searched you clicked in the topic and positioned it before the term.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20261
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Find (search) anomaly

Unread postby Dave Gehman » Fri Jun 15, 2018 1:32 pm

Some kind of strangeness, then. In the first, no-hit search, I had positioned the cursor at the beginning of the first topic.

On the second, topic-only search, I had the cursor at the top as well.

I just went down the TOC tree until I got to the topic where "chrome" actually appears. When I use "All topics from Here," there are no hits, even when starting at the top of the topic that contains "Chrome," second pic above.

I'm in Windows 10 Pro 64, latest @%$#@ Windows 10 update, H+M 7.3.5 4434. Last complete OS reboot, last night.
Dave Gehman
 
Posts: 275
Joined: Sat Sep 23, 2017 9:05 pm

Re: Find (search) anomaly

Unread postby Tim Green » Fri Jun 15, 2018 4:09 pm

Hi Dave,

Hmm... To make sure that we are both on the same page, please mail me a small project with which you can reproduce the effect at support AT ec-software.com (replace the AT with @) so that I can test it directly. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20261
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Find (search) anomaly

Unread postby Dave Gehman » Sat Jun 16, 2018 11:18 am

please mail me a small project with which you can reproduce the effect at support AT ec-software.com


I've done this. Thanks for taking it on.
Dave Gehman
 
Posts: 275
Joined: Sat Sep 23, 2017 9:05 pm


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: rodrikwade and 11 guests