Wrong display of variables

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Wrong display of variables

Unread postby Steffen Heller » Tue Nov 06, 2018 6:05 pm

Hello,

something is wrong with the way variables are displayed in my PDFs.
The following image shows what I mean:

Image

The name of the variable (in this case: # Name of the Variable #) is sometimes displayed correctly (like in chapter 1), sometimes it is moved to the left, covering the other text (like in chapter 2).
Both cases, right and wrong, can appear side by side, like here. On the topic page both variables look the same.

I think I already read about this in the forum. I just can't remember the exact explanation and couldn't find that other thread anymore.
But if an answer has already been given I am fine with a link to that other thread.
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Steffen Heller
 
Posts: 24
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria

Re: Wrong display of variables

Unread postby Tim Green » Wed Nov 07, 2018 6:42 am

Hi Steffen,

First, please update to the final release version of 7.4, released today:

https://www.helpandmanual.com/downloads.html?upd

Looking at your screenshot it's pretty clear that the problem is caused by using a font that doesn't have its own italic version. In cases like this Windows emulates italics by "bending" the normal font and this often throws the spacing in PDF off, which is much more sensitive to things like this than any other format. Version 7.4 has improved handling of emulated italics in PDF so it may help. However, it may also be that the font you are using has particular problems here. In that case it may help to change your font embedding option to Type3.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Wrong display of variables

Unread postby Steffen Heller » Wed Nov 14, 2018 7:51 pm

Thanks, Tim.
You are right, the problem lies in the combination of a certain font that cannot handle italic.
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Steffen Heller
 
Posts: 24
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 6 guests