Links with anchors don't work (eBooks)

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Links with anchors don't work (eBooks)

Unread postby Natalie Kraiczi » Thu Nov 15, 2018 1:18 pm

Hi,
my links between different eBooks do not work when using an anchor.

ProjectA.exe and ProjectB.exe are in the same directory.
Link "ABC" is in ProjectB.exe as file link:
- Text: ABC
- no tooltip
- style: Link
- file name: ProjectA.exe
- Relative path for export: empty
- execution parameter: index.html?ko.htm#Ziel

The anchor "Ziel" is contained in ProjectB.exe in topic ko.xml.

Any idea? It works for links without anchors.

regards,
Natalie
Natalie Kraiczi
 
Posts: 4
Joined: Wed Jan 13, 2016 8:32 am

Re: Links with anchors don't work (eBooks)

Unread postby Tim Green » Thu Nov 15, 2018 7:52 pm

Hi Natalie,

This may depend on the skin you are using. There are some skins for eBooks in the Premium Pack that use a different syntax. If that is the case look in the chapter of the Premium Pack help for that skin and you will find instructions for the linking syntax.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Links with anchors don't work (eBooks)

Unread postby Natalie Kraiczi » Fri Nov 16, 2018 9:39 am

It does not depend on a skin. I tested a V2 WebHelp + EWriter skin, a V3 eBook skin and an export without skin. In addition, the command line call does also not work, e.g. "ProjectA.exe index.html?ko.htm#Ziel". It opens the beginning of the page.
Natalie Kraiczi
 
Posts: 4
Joined: Wed Jan 13, 2016 8:32 am

Re: Links with anchors don't work (eBooks)

Unread postby Tim Green » Fri Nov 16, 2018 10:34 am

Natalie Kraiczi wrote:It does not depend on a skin. I tested a V2 WebHelp + EWriter skin, a V3 eBook skin and an export without skin. In addition, the command line call does also not work, e.g. "ProjectA.exe index.html?ko.htm#Ziel". It opens the beginning of the page.

The problem may be that you are using upper case letters in your URL. Anchors are always all lower case in output and HTML is case sensitive.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Links with anchors don't work (eBooks)

Unread postby Natalie Kraiczi » Fri Nov 16, 2018 1:12 pm

That's it! Thank you!
Natalie Kraiczi
 
Posts: 4
Joined: Wed Jan 13, 2016 8:32 am


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 9 guests