Image and table numbering mixed up

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Image and table numbering mixed up

Unread postby Steffen Heller » Tue Nov 20, 2018 9:38 pm

Hello,

exporting my project to PDF, I discovered that the numbering of tables and images is mixed up.
The numbers of the first tables in the document are 40, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62
With the numbering of images it is similar.

According to the explanation at https://www.helpandmanual.com/help/inde ... unters.htm ...

Every time Help+Manual encounters the variable in a project it increases its value by 1. This means if you want to start with 1 you must enter "0" as the variable's initial value when you define it. If you want to start with 10 you must enter "9" and so on (without the quotes).

1.Define a text variable with two + characters at the end of its name, for example ITEM++, VIEW++ and so on.
2.Set the value of the variable to 0 if you want to start counting at 1, to 89 if you want to start counting with 90 and so on. (Always one less than the number you want to use, the value is always incremented whenever the variable is used.)

... number 40 for the first and number 50 for the second table must have been set somewhere, right?

But how does that exactly work: "enter xxx as the variable's initial value when you define it"?
I tried things like <%TAB++=89%> or <%TAB=89%> but that didn't work.
And at "Configuration > Text variable" and "Task Manager > Publishing Task" the value is set to 0.
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Steffen Heller
 
Posts: 24
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria

Re: Image and table numbering mixed up

Unread postby Tim Green » Wed Nov 21, 2018 7:40 am

Hi Steffen,

But how does that exactly work: "enter xxx as the variable's initial value when you define it"?
I tried things like <%TAB++=89%> or <%TAB=89%> but that didn't work.
And at "Configuration > Text variable" and "Task Manager > Publishing Task" the value is set to 0.

The "when you define" it refers to the original definition of the variable in Configuration > Common Properties > Text Variables. The name of the variable in this case should be TAB++ and when you use it you should just enter <%TAB++%> and nothing else. That is for normal, user-defined counter variables. The internal resetting and definition options that you can add to figure and table counters don't apply here and can't be used.

The figure and table counters are separate and must use the special names defined in this topic:

https://helpandmanual.com/help/index.ht ... ersref.htm
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Image and table numbering mixed up

Unread postby Steffen Heller » Thu Nov 22, 2018 1:22 pm

Tim Green wrote:The "when you define" it refers to the original definition of the variable in Configuration > Common Properties > Text Variables. The name of the variable in this case should be TAB++ and when you use it you should just enter <%TAB++%> and nothing else. That is for normal, user-defined counter variables.

That is how I use it.
I have a user-defined variable called TAB++. To use it, I enter <%TAB++%>. In "Common Properties > Text Variables" its initial value is set to 0.

What I don't understand is why the output of that counter is 40, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62 and not 1, 2, 3, 4...

I thought perhaps...
* I have to additionally reset the counter to "0" somewhere -or-
* it was reset to "40" somewhere and I have to find and delete that code (the original document was not created by me, so it is possible that there are things that I am not aware of)

Another idea is this:
If I publish 5 documents at once (with a publishing task) will the counter keep on counting across all the documents?
Will document 2 start with the counter set to 40 if numbers 1 to 39 were already used in document 1?
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Steffen Heller
 
Posts: 24
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria

Re: Image and table numbering mixed up

Unread postby Tim Green » Thu Nov 22, 2018 7:48 pm

Hi Steffen,

The variable must be being reset somewhere to pick up these values. Either that, or it is being used or set somewhere else in the same project and so incrementing the counter.

If I publish 5 documents at once (with a publishing task) will the counter keep on counting across all the documents?
Will document 2 start with the counter set to 40 if numbers 1 to 39 were already used in document 1?

I'm not quite sure what you mean by "documents". If you mean topics in the same project, the variables will keep their value throughout the same project if they are not reset, If you mean different projects then no, there is no carry-over between projects unless they are all being published together in a common modular project (inserted in the same master project). Then variables with the same names will carry throughout the master project, of course.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Image and table numbering mixed up

Unread postby Steffen Heller » Mon Nov 26, 2018 8:56 pm

Hi Tim,

I found the reason for my problem.
It is the fact that I was using <%TOTAL_PAGE_COUNT%> in my Design Template.
Picked it up at https://helpman.it-authoring.com/viewto ... 30&t=12365 but didn't read the full thread at first :frustration:
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Steffen Heller
 
Posts: 24
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria

Re: Image and table numbering mixed up

Unread postby Tim Green » Tue Nov 27, 2018 8:02 am

Steffen Heller wrote:I found the reason for my problem.
It is the fact that I was using <%TOTAL_PAGE_COUNT%> in my Design Template.

Thanks for confirming this. That is something that I had actually forgotten about -- since it forces the PDF to be generated twice it will double up all your counter variables as well... :?
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 6 guests

cron