Webhelp Full Text search does not give any results

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Post Reply
VincentBevort
Posts: 90
Joined: Wed Mar 30, 2016 1:53 pm
Location: Stockholm, Sweden
Contact:

Webhelp Full Text search does not give any results

Unread post by VincentBevort » Fri Nov 08, 2019 1:39 pm

I have a project where the full-text search option does not give any results. See image.

The strange thing is:
- When I use the search when H&M compiled the output, it works
- When I copy the site to my localhost, it works
- When I copy the site to our document server, it does NOT work.
I verified the zoom-index.js file on the server. It has the same search indexes as on my local copy.
Other projects created with the same skins and settings do work on the document server.
I tried different skins to rule out problems with the skin I use.
I deleted all files from the server and copied the files from the localhost to the server
It feels like it just does not show anything. As you can see, the search box disappears and only comes back when I refresh the browser (Google Chrome) with F5
So it must be something in my project but I cannot find it.

I am using H&M 7.5.3 build 4740 with the V3 responsive WebHelp skin Flat_Slate_Blue_WebHelp
You do not have the required permissions to view the files attached to this post.
Senior Test Engineer & Technical Writer
Flowbird group

User avatar
Tim Green
Site Admin
Posts: 21307
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Webhelp Full Text search does not give any results

Unread post by Tim Green » Fri Nov 08, 2019 3:09 pm

Hi Vincent,

If it's working locally that confirms that the problem is not in the output, which has to be OK. There is something wrong on the server end: For example, not all files were uploaded, files were damaged, or something on the server is blocking the search function.

The first thing to do is to reload without the browser cache with CTRL+F5, which makes sure that no old cached files are causing errors. If it still doesn't work press F12 to display the JavaScript console while accessing the WebHelp and trying to search to see if you are getting any errors there.

Also, don't use a "smart" FTP program to only upload "changed" files. Those programs aren't smart and they don't work. Delete all the existing files in the server folder before uploading and upload everything from the output folder, without any exceptions.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

VincentBevort
Posts: 90
Joined: Wed Mar 30, 2016 1:53 pm
Location: Stockholm, Sweden
Contact:

Re: Webhelp Full Text search does not give any results

Unread post by VincentBevort » Mon Nov 11, 2019 8:37 am

Thanks Tim,

Will try and ask one of our developers if needed.
Senior Test Engineer & Technical Writer
Flowbird group

Post Reply