Broken Help in HelpXplain

HelpXplain is the exciting new animated infographics and screencast tool that integrates with Help+Manual.

Moderators: Alexander Halser, Tim Green

Post Reply
Tim Frost
Posts: 247
Joined: Mon Nov 22, 2004 11:45 pm

Broken Help in HelpXplain

Unread post by Tim Frost » Tue Jun 25, 2019 10:47 pm

Only just installed the product in trial mode. Working through the help file for HelpXplain I see a lot of Script Error dialogs, almost all the same one, popping up in different topics when switching from one topic to another. For example on clicking in the Contents from "Single-slice Xplains" to "Make and Image Slider" the dialog pops up, but on clicking from "Make a HowTo Screencast" back to the same topic, I get no popup. and the slider demo is fine. This is Windows 10 64-bit, build 1809 and all he pop-ups are repeatable, or absent as I describe above, if the same sequence of steps are used to reach them. I think I may also have seen one of these when clicking one of the examples on the welcome page, but I am not sure, there were so many of them in the help file which was on top of that page.
2019-06-25_22-18-02.png
You do not have the required permissions to view the files attached to this post.

User avatar
Tim Green
Site Admin
Posts: 21203
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Broken Help in HelpXplain

Unread post by Tim Green » Wed Jun 26, 2019 6:09 am

Hi Tim,

Thanks for reporting this. Unfortunately, we can't reproduce this anywhere. What hardware are you running on, i.e. processor type and speed (if you know them), amount of memory? I ask because errors like this that occur with the same file on specific computers only are sometimes timing problems.

Another question is whether you have restarted Windows recently or if it has just been going to sleep every day for a while rather than being restarted.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

Tim Frost
Posts: 247
Joined: Mon Nov 22, 2004 11:45 pm

Re: Broken Help in HelpXplain

Unread post by Tim Frost » Wed Jun 26, 2019 10:30 am

Core I7-6700T, 2.80GHz, 8GB RAM, and drive C is an M2 SSD. The machine is turned off every night, and turning off is configured to really turn off, which seems not to be the default these days. Today the pop-ups still occur, but some of the topics affected yesterday are feeling better today. So this is consistent with timing errors, but I have never seen pop-ups before in any other CHM, except in genuinely broken ones (so of course, not H&M ones).

If I open the CHM directly, the pop-ups occur on fewer topics than when it is opened from the Help button. When I copied the CHM to an older machine running W7 (I7, 3.4GHz, 8GB) the pop-up occurred there once on one topic and thereafter not at all.

User avatar
Tim Green
Site Admin
Posts: 21203
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Broken Help in HelpXplain

Unread post by Tim Green » Wed Jun 26, 2019 11:21 am

Hi Tim,

Update: I could now reproduce the error and I've located the problem. It was caused by an excess of caution: The new HelpXplain help includes the latest version of jQuery, but it turns out that is not entirely compatible with CHM because of the old Internet Explorer rendering mode that the CHM viewer uses. We just need to recompile it with the last jQuery 2.x version instead of the latest jQuery 3.x version. Will be fixed ASAP. This also isn't a security problem because CHM files don't offer an attack surface on the Web. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

User avatar
Martin Wynne
Posts: 2550
Joined: Mon May 12, 2003 3:21 pm
Location: West of the Severn, UK

Re: Broken Help in HelpXplain

Unread post by Martin Wynne » Wed Jun 26, 2019 11:23 am

I'm not seeing those errors, but I am seeing content duplicated in places. For example in Introduction > The User Interface a screenshot and the text below it appears 3 times. I noticed the same thing in several other places.

CHMs play up so often that I tend to ignore it. (Windows 10).

cheers,

Martin.

User avatar
Tim Green
Site Admin
Posts: 21203
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Broken Help in HelpXplain

Unread post by Tim Green » Wed Jun 26, 2019 11:31 am

Hi Martin,

Wow, thanks for noticing that. Also seems to be jQuery related. I could see it in the version with the incompatible jQuery but not in the version with the older jQuery. We'll look into it. :shock:
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

Post Reply