Screencast Script error

HelpXplain is the exciting new animated infographics and screencast tool that integrates with Help+Manual.

Moderators: Alexander Halser, Tim Green

Screencast Script error

Unread postby alanmcd » Sat Jul 13, 2019 4:17 am

I have just bought HelpXplain and I have H&M 7.5.1
I have created a couple of screen casts and included/compiled them into my help chm file.
On my PC it all works fine
But on my client's PC it fails with attached error message.

Pretty disappointed in this - obviously(?) a permissions issue with the scripting execution in the screen cast?
Makes it all pretty useless for my doing this for my client unless I direct them to a browser loaded version.

Is that my only choice?
Alan
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
alanmcd
 
Posts: 89
Joined: Thu Jan 06, 2005 3:02 pm

Re: Screencast Script error

Unread postby Tim Green » Sat Jul 13, 2019 8:26 am

Hi Alan,

This is unusual., What version of Windows and Internet Explorer is your client's PC running?
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20887
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Screencast Script error

Unread postby alanmcd » Sat Jul 13, 2019 8:38 am

OK yes, I've just finished upgrading the DB server I have the database on. from IE 8 to 11 and it now works. I'm hoping that's the issue. But my clients run in Citrix and I'm at the mercy of their permissions and versions.. Should i expect the possibility of the CHM file faulting on the HeplXplain content? Or should I have no problems with current IE version etc.
My client (Government) is notorious for blocking things in the name of security. I was hoping this solution would avoid that radar..
Alan
alanmcd
 
Posts: 89
Joined: Thu Jan 06, 2005 3:02 pm

Re: Screencast Script error

Unread postby Alexander Halser » Sat Jul 13, 2019 10:00 am

Hi Alan,

I sent you a private message with an updated loader script. This script is responsible for the error - the Xplain itself will test if it can run and display a fallback message if the browser is not capable.

Generally speaking, Xplains run on MSIE 9 or later (released in 2011) and most desktop browsers of its generation. It is unlikely that people surf the web wich browsers that old, for this would be an extreme security hazard. But in CHM files it is more likely to come across an old system with a really old MSIE 7 or 8. CHM files always use an embedded Internet Explorer for display, so there's no browser choice.

We are going to deliver the updated loader script with the next HelpXplain update. This handles MSIE 7/8 more gracefully.
Alexander Halser
Senior Software Architect, EC Software GmbH
User avatar
Alexander Halser
EC-Software Support
 
Posts: 3940
Joined: Mon Jun 24, 2002 7:24 pm
Location: Salzburg, Austria

Re: Screencast Script error

Unread postby alanmcd » Sat Jul 13, 2019 12:58 pm

Thanks Alex,
As I said, I got it working without the message that just said "get a decent browser"
I still need to get it confirmed inside Citrix. I was just worried that I would get a permissions issue running scripts etc. But I'll keep my fingers crossed.
Alan
alanmcd
 
Posts: 89
Joined: Thu Jan 06, 2005 3:02 pm


Return to HelpXplain Infographics Tool

Who is online

Users browsing this forum: No registered users and 1 guest

cron