Help & Manual Toolbox 1.26 Beta

The latest news, information and updates.

Moderators: Alexander Halser, Tim Green

Help & Manual Toolbox 1.26 Beta

Unread postby Tim Green » Mon Jul 08, 2013 11:33 am

Beta Ended

The beta test of HM Toolbox has now been ended. The utility has now been renamed Premium Pack Toolbox and is included in the Help & Manual Premium Pack from version 3, with new options and capabilities for interacting with Premium Pack skins (configuration, language files etc.) I'm afraid I don't have the resources to maintain two parallel versions, so this version is now closed.

==================================================================================================================

Help & Manual Toolbox is a utility I've produced for power users who need to do a few key things with their projects that are not possible from within Help & Manual itself. I wrote the original version as a tool for myself for working on skins and templates, because I wanted to be able to edit the HTML templates stored in projects with an external, full-featured editor without having to copy them out and then back again. Since then I've added a lot of other features that will make it more generally useful.

Current Version: 1.26 Beta
Expiry date update and support for Premium Pack 3 configuration variables. See here for details.

Click here to download Help & Manual Toolbox Beta installer

IMPORTANT: Always create backups of your projects before working on them with this tool. Even without potential bugs, it's easy to do a lot of damage when working directly on your source code if you're not careful!

What you can do with Help & Manual Toolbox

  • Edit the HTML templates in your skins and projects in an external editor of your choice:
    When you do this, HM Toolbox monitors your edits and can save them back to the project directly, either when you select Save in Toolbox, or automatically every time you save in your external editor. This radically speeds up working on skin projects.
  • Export author comments:
    Find all the author comments in your project and export them to a text file for archival or printing. Sort in TOC order, by topic ID or in the natural file order. Export as plain text, RTF or CSV with headers for Excel.
  • Edit your baggage files in the same way as your templates:
    Same process as for the HTML templates. Also supports graphics files edited with an external graphics editor.
  • Test publish with the current skin:
    Publishes a project with the current skin so that you can test your work without leaving the utility
  • Add/Remove topic ID prefixes globally:
    If you decide you want to add a projects to a modular project structure you will often want to add prefixes to topic IDs globally to prevent ID collisions with other projects. This tool does this for you and it can also remove existing ID prefixes. When adding prefixes it can also skip topics with existing prefixes so that you don't get double prefixes. It automatically updates all internal links, context ID numbers, TOC references. etc.
  • Add/Delete/Rename build options:
    When you rename build options you can automatically update all references to the build option in your project (TOC, Topic Files, Baggage Files) and your topics (conditional text tags) at the same time.
  • Complex search and replace in topic XML source code:
    This gives you five different ways to to do this, including full optional support for regular expressions. It automatically handles the carriage returns and whitespace between XML tags in all modes, so you don't to worry about those at all, and it also automatically compensates for different ways of handling quotes in XML source code. It has a preview function so that you can check the results before changing a project and checks for XML errors before writing anything back to your topics.
  • Save and load search profiles:
    Profiles for complex searches can be stored and loaded from .hmsearch XML profile files allowing you to reuse and share complex searches for any number of tasks.
  • Add non-skin settings to skins:
    Skins created in Help & Manual only allow you to add a limited set of project settings that can be controlled by skins. You can get around this by writing XML skins by hand, but that's complex, time-consuming and difficult. HM Toolbox allows you to add almost all normal project settings to skins, enabling your skin to control things that weren't previously possible. For example you can insert a set of alternative Project Search Path entries so that projects published with your skin get their graphics from a different folder. All the settings have popup help explaining what the setting does, how to alter it and how to use it in projects and skins.
  • Configure your Premium Pack skins with popup help:
    The tool identifies Premium Pack skins automatically and allows you to edit all the configuration variables they contain in organized groups, with popup help for every configuration variable explaining its settings and how to use it.
  • Check your project for common errors:
    Loading a project automatically checks and warns about invalid project search path entries and duplicate files in folders stored in your project search paths. In addition to this you can also run a check for embedded images that will list all the topics that contain embedded images you need to convert to external files (just select Initalize Topics in the File menu). A number of other checks for XML errors, file errors and other inconsistencies are also run and reported when you load a project.

INSTALLATION, REQUIREMENTS AND CONFIGURATION:

It's a fully signed installer with signed executables so you can install it directly. It will ask to install in its own new directory in the EC Software program directory and that's the best place for it.

You must have Help & Manual 6 or 7 installed (don't try to use it with earlier versions) and you also need Microsoft .NET Framework 4 or higher.

Before using it you need to select Edit > Preferences and choose a code editor for editing HTML and source code files. This should allow access to the files while you are editing because HM Toolbox needs to be able to save your changes back to your project as soon as you save in your editor (it monitors the editing files for changes and updates them automatically if you want). If you aren't using one already I recommend notepad++, which is free and outstanding. I use it for all my template editing work and there is a wealth of great plugins you can use. You can get it here:

http://notepad-plus-plus.org/download/v6.3.3.html

You also need to set a graphics editor for editing files in the baggage directly, but Impict is set for that by default so that you can also edit .ipp files if necessary.

LIMITATIONS:

Please note that at the moment this tool won't work on .hmxr repositories, just on .hmxz, .hmxp and .hmskin projects. It also won't read TOC files that have been manually split into more than one XML file (it will report the TOC as invalid) and it won't read child projects of master projects. It will also only edit the "Default" topic page template. It will not currently load additional topic page templates, even if they have been defined in your project.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Fri Jul 12, 2013 7:59 am

Update to 1.0.57 Beta

This update just makes some improvements to the test compile dialog

  • Support index.php as well as index.html in test compiles
  • Allow direct editing in source project and target output fields in test compile dialog.
  • Automatically turn off publish button if source project or output folder don’t exist
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Sun Aug 11, 2013 11:05 am

Update to 1.0.71 Beta

Quite a few changes and improvements in this update:

New and Improved:
  • Right-click context menus for variables, build options and baggage files
  • Double-click now supported for editing baggage files
  • Delete now supported for baggage files
  • Build options: You can now add, delete and rename build options. All functions available in right-click menu and Edit menu. When you rename build options you can automatically update all references to the option in both the project files (TOC, topic files, baggage files build options) and topic files (conditional text tags)
  • Variables: You can now add and delete variables. Right-click menu for Edit Value, Add, Delete and Help.
Fixes:
  • Variables option was still active when switching from variables to baggage editing
  • Fixed crash when attempting to open projects versioned in Microsoft Visual SourceSafe (this is not permitted, an error message is now displayed)
ToDo List:
  • Rename variables and update all references to the variable
  • Save As option for saving projects and skins in another location
  • Edit search options in project and skin settings
  • Add build options to baggage files settings
  • Add context help for Premium Pack baggage files
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Thu Aug 29, 2013 6:16 pm

Update to 1.0.86 Beta

Changes and improvements in this update (expires September 30):

New and Improved:
  • Rename variables and automatically update all references to the variable
  • Save As option for saving projects and skins in another location
  • Edit WebHelp search options in project and skin settings
  • Change build options for baggage files
Fixes:
  • References to build options in publishing tasks were not updated when renaming builds
  • Current folder was set to folder of previous project instead of current project when opening a project from the Recent Projects list
ToDo List:
  • Save/Load complex multi-topic source code searches to/from XML files. This will make it possible to distribute predefined searches for complex problems that you can just load and run.
  • Add context help for Premium Pack baggage files
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Tue Sep 24, 2013 4:35 pm

Update to 1.0.95 Beta

Changes and improvements in this update (expires October 31):

New and Improved:
  • Save/load complex searches to/from .hmsearch XML files
    This makes it possible both to save useful searches for reuse, and to share searches with other people. For example, if you post a request for something you want to achieve on the forum, we would be able to craft a search for you that you could then just load and run.
Fixes:
  • Error when renaming Build IDs and variables in projects without any custom HTML templates (a spurious dialog was displayed and references in the TOC were not updated)
  • Search/Replace preview dialog was not on top when opened
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Fri Nov 01, 2013 6:01 pm

Update to 1.0.98 Beta

Changes and improvements in this update (expires October 31):

New and Improved:
  • Confirmation dialog added reminding you that the project was saved automatically after adding baggage files
Fixes:
  • "Delete variable" function didn't delete the variable when AutoSave was off
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Sat Nov 02, 2013 7:09 am

Update to 1.0.99 Beta

Changes and improvements in this update (expires October 31):

Fixes:
  • It wasn't possible to add new variables or build options for projects that didn't already have at least one variable or build option. (Oops... :mrgreen: )
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Mon Nov 25, 2013 10:58 am

Update to 1.0.102 Beta

Changes and improvements in this update (expires December 25, 2013):

Changes:
  • You can now also edit projects stored in Visual SourceSafe repositories if you manually turn off all the file locks beforehand (use this option at your own risk!)
Fixes:
  • Corrected a bug in the option for editing JavaScript popup settings in skins and projects (changes weren't saved correctly in the last update).
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Wed Nov 27, 2013 2:14 pm

Update to 1.0.103 Beta

Changes and improvements in this update (expires December 25, 2013):

Changes:
  • New application icon that doesn't disappear against grey backgrounds... 8)
  • File extension for saved search profiles is now also added automatically if you type the file name manually. If you type in an incorrect file extension it is automatically replaced with the correct one.
Fixes:
  • Corrected a crash that occurred if you manually entered a search profile name that didn’t exist in the Save dialog
  • Complex search and replace: In some circumstances the InnerA, InnerB and End arguments could be replaced by empty strings if the replacements were not explicitly specified.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Mon Dec 02, 2013 3:33 pm

Update to 1.0.104 Beta

Changes and improvements in this update (expires December 25, 2013):

Fixes:
  • Corrected a crash that occurred in searches in topics without headers that do not have a title element defined. These topics will now be listed as "Untitled topic" in the search results.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Thu Dec 05, 2013 4:47 pm

Update to 1.0.105 Beta

Changes and improvements in this update (expires December 25, 2013):

Fixes:
  • If you used the test compile option with one skin and then loaded a new skin without restarting HM Toolbox, selecting test compile again would compile with the previous skin, not the current skin.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Tue Dec 31, 2013 8:54 am

Update to 1.0.106 Beta

Changes and improvements in this update (expires February 01, 2014):

Changes:
  • You can now set the Sync Timestamp and Sync Archive Bit options in the Edit HTML Settings section
  • Added an option for keeping or deleting sub-folders when test publishing
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Nicolas Wicke » Thu Jan 23, 2014 8:54 am

Hi Tim,

When using the Add/Remove Topic ID Prefixes function of the Toolbox (great tool, by the way :applaud:), I always get the following error after the operation:

Image

After this error, the normal confirmation message is shown and the prefixes have effectively been added.
The only thing I do is add a prefix (max. 5 characters) to a project with no existing prefixes.

Not a big problem, I would guess, however I thought I'd let you know :).
The error message is partly in Dutch, but I'm sure you will be able to see what's going on.

Best regards,
Nicolas
User avatar
Nicolas Wicke
 
Posts: 135
Joined: Thu Nov 10, 2011 8:58 am

Re: Help & Manual Toolbox Beta

Unread postby Tim Green » Thu Jan 23, 2014 11:45 am

Hi Nicolas,

I haven't used this function in a while but I just tested it again and it's working fine. Please mail me a small example of a project you're getting this error on and I'll check it. There must be something about the project or the existing IDs that the routine is gagging on. Save the project in single-file .hmxz format and mail it to support AT ec-software.com (replace the AT with @) and I'll check it out.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20355
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Help & Manual Toolbox Beta

Unread postby Nicolas Wicke » Thu Jan 23, 2014 11:55 am

Hm, strange... it seems the error only occurs with hmxp projects.

When preparing a project (hmxp saved to hmxz) to send to you, I re-tested in the toolbox and I didn't get the error. I then saved to hmxp, retried and dit get the error.
I've sent the project anyway.

Thanks.
User avatar
Nicolas Wicke
 
Posts: 135
Joined: Thu Nov 10, 2011 8:58 am

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 6 guests