Restoring Compatibility with Current Tortoise SVN

The latest news, information and updates.

Moderators: Alexander Halser, Tim Green

Restoring Compatibility with Current Tortoise SVN

Unread postby Tim Green » Thu Aug 11, 2016 4:35 pm

IMPORTANT: This works for both Help+Manual 7 and Help+Manual 6

As you will know if you use Subversion, recent changes to the Tortoise SVN client have made it necessary to downgrade to Tortoise SVN 1.9.2 to maintain compatibility with Help+Manual 6 and 7. This is potentially problematic in the long term, because it means that your version of Tortoise may no longer match the current version of your Subversion Server.

We now have a solution for this that works for both Help+Manual 7 and Help+Manual 6. We are going to provide more integrated support for it in the next update to H+M 7, but you can install the solution now and it will work fine. All you need to do is update Tortoise and then install the current 32-bit SVN client from Collabnet. The download is free, but at the moment you do need to register with Collabnet to get it. We are looking for a better solution for this.

All components must have the same version!

The only caveat is that you must make sure that all components have the same version. The version number indicates the Subversion version, so currently your Subversion server, Tortoise and the Collabnet client should all be version 1.9.4. If you update any of the components in the future you should update ALL of them to the same number again.

Step 1: Update Tortoise to the current version

This is Tortoise SVN 1.9.4. It is important that you DON'T use 1.9.3 -- that was an intermediate version and it will continue to confuse Help+Manual's SVN client access. You can always download the current Tortoise SVN version on this page:

https://tortoisesvn.net/downloads.html

Step 2: Download and install the 32-bit Collabnet client

When you click on the download link on this page you will first need to complete a free registration with Collabnet before you can proceed:

http://www.collab.net/downloads/subversion

IMPORTANT: You ONLY need the 32-bit command line client, even on 64-bit Windows. In the current version this is titled "Subversion 1.9.4 (Windows 32-bit)" and is 6.16MB. This is the only component that is missing to make the current version of Subversion work properly with Help+Manual.

collabnetdownload.png
This is the only installer you need!
collabnetdownload.png (22.38 KiB) Viewed 2721 times

After downloading, run the installer and accept the default location it chooses for installation.

Step 3: Restart Help+Manual

Subversion functions should now work properly without any further action on your part. In the unlikely event that there are problems, select the Collabnet client manually in View > Program Options > Subversion. It is installed in C:\Program Files (x86)\CollabNet\Subversion Client and the file you need to select is "libsvn_client-1.dll".
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20203
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Restoring Compatibility with Current Tortoise SVN

Unread postby anders_g » Tue Feb 20, 2018 1:58 pm

Is this still a problem with the latest H&M7? In that case there is a problem, because Collabnet doesn't provide the 1.9.4 download any more.
I just installed H&M (latest version) on a new computer, and it didn't find any libsvn_client-1.dll...


/Anders
Anders Gustavsson
Lund, Sweden
anders_g
 
Posts: 34
Joined: Mon Sep 02, 2002 4:49 pm
Location: Lund, Sweden

Re: Restoring Compatibility with Current Tortoise SVN

Unread postby Tim Green » Tue Feb 20, 2018 3:33 pm

Hi Anders,

This is necessary because Tortoise continues to not provide the 32-bit components with its 64-bit installation. These components are necessary on 64-bit Windows for 32-bit programs like Help+Manual to be able to communicate with Tortoise and SVN.

You don't need the 1.9.4 version. You just need to have all three components of the matching version -- SVN, Tortoise and Collabnet. SVN and Tortoise are usually exactly in sync, but Collabnet is usually a little slower. So check all three components and stay with the one that currently has the lowest number. This posting on our news blog is more up to date, but the individual components may have been updated since then:

http://news.helpandmanual.com/2016/08/r ... toise-svn/

Unless you have an urgent specific need to update it is generally never necessary to update the SVN components as soon as they are released. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20203
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Restoring Compatibility with Current Tortoise SVN

Unread postby Francis Langlois » Tue Sep 18, 2018 12:06 am

I know this periodically rears its head. I installed H&M on a new computer now the SVN clients that are available don't sync. That is, Tortoise has a 1.10.1 64-bit version available and the collab.net 32-bit clients that are available are 1.10.0 and 1.10.2. So I am out of luck getting the SVN functionality in H&M to work. That is, unless there is something else to do. I also installed the VC -redist but no luck. I can't fall back either because the only 1.9 versions available do not match. Just hoping there is another answer other than wait for a new one of the two.
Francis Langlois
 
Posts: 18
Joined: Fri Dec 11, 2015 1:05 am

Re: Restoring Compatibility with Current Tortoise SVN

Unread postby Tim Green » Tue Sep 18, 2018 6:52 am

Hi Francis,

Francis Langlois wrote:That is, Tortoise has a 1.10.1 64-bit version available and the collab.net 32-bit clients that are available are 1.10.0 and 1.10.2. So I am out of luck getting the SVN functionality in H&M to work.

This has only just cropped up: For reasons unknown, Tortoise has compiled their 1.10.1 version against SVN 1.10.2, i.e. without increasing their version number accordingly. (My guess is that nothing needed to be changed, but that's just a guess.) The problem is, this throws off the version number check for Tortoise against the Collabnet component.

We're looking into a way to get around this, stay tuned. However, there is really NO pressing need to update the Tortoise and Collabnet components for HM if they are already working OK for you. For example, if you are using 1.9.7 or even 1.9.5 they both still work fine and it is no problem to stay with them. Actually, any 1.9 version should be fine; just don't try to go back to 1.8, because the project format changed between 1.8 and 1.9 (but not between 1.9 and 1.10).
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20203
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Restoring Compatibility with Current Tortoise SVN

Unread postby Tim Green » Tue Sep 18, 2018 9:55 am

Update: The current stable beta will now let you combine Tortoise 1.10.2 with Collabnet's 1.10.2 32-bit component. You can download it here:

https://www.helpandmanual.com/download/ ... p-v740.exe

Actually, it will allow any combination of 1.10.0 through 1.10.2, just to make sure. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20203
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Restoring Compatibility with Current Tortoise SVN

Unread postby Francis Langlois » Wed Sep 19, 2018 4:03 am

Worked perfect. Thanks.
Francis Langlois
 
Posts: 18
Joined: Fri Dec 11, 2015 1:05 am


Return to Announcements

Who is online

Users browsing this forum: No registered users and 3 guests