Two entries not displayed properly in TOC

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Post Reply
User avatar
Steffen Heller
Posts: 29
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria

Two entries not displayed properly in TOC

Unread post by Steffen Heller »

Hello everybody,

I just recognized that there is an error in my table of content. Two entries are not displayed properly. The attached screenshot shows what it looks like.
TOC_error.png
I tried to find something where these lines are different from others, but the chosen text style in Editor view or the code in XML view is the same as on other pages with no problem.
Any idea what that could be?
You do not have the required permissions to view the files attached to this post.
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Tim Green
Site Admin
Posts: 22777
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Two entries not displayed properly in TOC

Unread post by Tim Green »

Hi Steffen,

This is an error in your PDF template. The anchors for the TOC entry objects in the TOC section are not set correctly. You need to display the properties for each TOC entry object and set its anchor to top / left / right but not bottom.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Steffen Heller
Posts: 29
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria

Re: Two entries not displayed properly in TOC

Unread post by Steffen Heller »

Thanks so far.
I haven't fully understood and must go step by step:

What file is the PDF template?
Is it the file at Templates & Skins > Templates used with this project > {custom_name}.mnl
that looks like this
TOC_error2.png
My "problem" with this file is this:
I have two different documents (German and English) with different versions of this PDF template.
When I publish to PDF, one PDF is correct (the German PDF), one shows the error (the English PDF).
I have now tried to export the English document with the German PDF template and was hoping that the error dissappears when I change the PDF template but that was not the case.
You do not have the required permissions to view the files attached to this post.
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Tim Green
Site Admin
Posts: 22777
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Two entries not displayed properly in TOC

Unread post by Tim Green »

Your screenshot shows that you have Word Wrap turned off. If you activate that checkbox again it should solve the problem. :)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Steffen Heller
Posts: 29
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria

Re: Two entries not displayed properly in TOC

Unread post by Steffen Heller »

I activated the word wrap checkbox but that didn't solve the problem.

This is how the (almost) whole TOC looks like:
TOC_error3.png
There are many other entries that are displayed correctly, only these two have a problem.
Isn't that an indication that there is something wrong with these specific entries/headline and not with the settings of the PDF template?
You do not have the required permissions to view the files attached to this post.
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Tim Green
Site Admin
Posts: 22777
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Two entries not displayed properly in TOC

Unread post by Tim Green »

Hi Steffen,

This is a little odd. Check the topic headers and TOC captions of those topics for empty paragraphs and spaces before the beginning of the title. If that doesn't help, please mail me your PDF template and a small demo project containing just a few topics, including the two affected topics. You can create this by selecting Save As... in the File menu and choosing the single file compressed option. Then delete all the unnecessary topics in the copy, and finally go to Configuration > Common Properties > Miscellaneous. There, turn off the history function and purge all the history files from the copy. That will create a nice compact project file for mailing.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Steffen Heller
Posts: 29
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria

Re: Two entries not displayed properly in TOC

Unread post by Steffen Heller »

Thanks for the offer, Tim.
I don't seem to get that solved and will send you a demo of my files.
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Tim Green
Site Admin
Posts: 22777
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Two entries not displayed properly in TOC

Unread post by Tim Green »

Hi Steffen,

Thanks for the files. The problem was the separate dot leader object, which was still anchored to "bottom", and combined with the settings for the title object that confused the layout. I've replaced it with the new automatic dot leader and page number variable in the title variable object and everything looks fine now. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Steffen Heller
Posts: 29
Joined: Tue Oct 16, 2018 2:35 pm
Location: Austria

Re: Two entries not displayed properly in TOC

Unread post by Steffen Heller »

Hello Tim,

I could now solve it.
I took the faulty files, kept going replace a part of it + publish until the exported PDF looked good.
In the end, overwriting the topic title in the left Project Explorer with nonsense, save it and then enter the correct title again made the difference:
fertig.png
Thanks a lot for your support, both here and via email.
You do not have the required permissions to view the files attached to this post.
Thanks for helping
Steffen
My current Version: 7.4.0 Build 4590
User avatar
Tim Green
Site Admin
Posts: 22777
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Two entries not displayed properly in TOC

Unread post by Tim Green »

Hi Steffen,

Glad to hear you got it fixed. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
Post Reply