External links do not work in chm

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Post Reply
ElenaMenci
Posts: 3
Joined: Wed Apr 14, 2021 8:04 am

External links do not work in chm

Unread post by ElenaMenci »

This is the first time I've set up a H&M manual by myself, and I can't understand which setting I should change.

I am using Help&Manual 7.5.4, build 4760. I've worked on manuals set up by others so far with no issue. I've set up my first manual from scratch, and everything was working fine. All internal and external links are functioning in the editor. All internal and external links are functioning in pdf. But if I publish the manual in chm, the external links do not work. If I click on an external link, I get a long series of "script errors".

I've looked up in the publishing options and in the general options, but I couldn't find anything that would fix this. I don't even know where to start from to fix this! Could anyone help me out here?

Thanks in advance!
User avatar
Tim Green
Site Admin
Posts: 23245
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: External links do not work in chm

Unread post by Tim Green »

Hi Elena,

What kind of links are you using that are not working? The CHM system is highly restricted by Windows for security reasons because of its internal reliance on the ActiveX system, which provides full, unrestricted access to the entire computer. This system effectively makes a CHM file as potentially dangerous as an EXE file, with the ability to do pretty much anything on the user's system. Because of this CHM files are entirely blocked on network drives and web servers, and many external link types are completely blocked as well.

Background: The CHM system was released in 1998 with Windows 98 and has not been changed at all since then. Microsoft has never updated it or even fixed any of the many original bugs it was released with. It does not support Unicode, high-resolution monitors or many current HTML, JS and CSS standards. Effectively, Microsoft abandoned it directly after releasing it. It only still works because each version of Windows has been programmed around it -- more recently also to block its many gaping security holes :?
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
ElenaMenci
Posts: 3
Joined: Wed Apr 14, 2021 8:04 am

Re: External links do not work in chm

Unread post by ElenaMenci »

Hi Tim,

Thank you for your reply! The links that are not working are two, and they both point at our website, a simple https webpage. My colleague showed me a chm manual for another program (not our manual, we don't know how they compiled it) where this type of link worked, and the only difference, if you look at the properties, is that ours follows a "Hypertext Transfer Protocol with Privacy" while the other follows a "Hypertext Transfer Protocol". I don't know if this is meaningful, and I don't know if there's a workaround available in Help&Manual. Do you confirm it is not possible? Or can you give us a solution?
User avatar
Tim Green
Site Admin
Posts: 23245
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: External links do not work in chm

Unread post by Tim Green »

Hmm. Normal web links including the http:// or https:// protocol at the beginning of the URL should work normally on CHM. Make sure that you are using the Internet Link option in Help+Manual to create the links, and set the Target Window setting to "new window", not any of the other options. The URL should also not contain any spaces, special characters, accented characters etc. The CHM system is highly allergic to anything like that.

If you continue to have problems, send me a small demo project at support AT ec-software.com (replace the AT with @) and we'll check it for you directly. You can create this project as follows:

​1: Select Save As.. in the File menu and save the project in the single-file HMXZ format (first option, single file storage).
2: Delete any topics not needed for the demo.
3: Go to Configuration > Common Properties > Miscellaneous. Turn off "Automatically create history files" and delete the history in the project with the "Purge xx history files" button. Then save again.
​4: Perform a test to make sure you can still reproduce the issue with the demo project.​
​5​: Send us the resulting .hmxz file and also the .hmskin skin file you are using to generate your CHM, if you are using one.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
ElenaMenci
Posts: 3
Joined: Wed Apr 14, 2021 8:04 am

Re: External links do not work in chm

Unread post by ElenaMenci »

Thanks Tim, it was the target window! I hadn't set it right. Now it's working!
Post Reply