Cannot load G:\. . . \ . . . .hmxz

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Post Reply
JeremyBelina
Posts: 1
Joined: Thu May 12, 2016 3:44 pm

Cannot load G:\. . . \ . . . .hmxz

Unread post by JeremyBelina » Fri May 13, 2016 7:45 am

I have just moved my H & M onto another computer. I had been using Version 7 previously but upgraded to the latest build, 3791 on the new computer.

When I come to open the project it comes up with:
"Cannot load G:\. . . \. . . hmxz. Please ensure that you have sufficient rights to open the project. ProjectOpen: The project file project.hmxp can not be found in archive C:\DephiXE6\ECS\EC\HMDAL.pas, line 6721".

I would appreciate some assistance in how to get going again.

User avatar
Tim Green
Site Admin
Posts: 21610
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Cannot load G:\. . . \ . . . .hmxz

Unread post by Tim Green » Fri May 13, 2016 10:16 am

I had been using Version 7 previously but upgraded to the latest build, 3791 on the new computer.
That won't be a problem at all and won't be related to your current issue.

If you're just selecting one of the options for reopening a project that you've already edited it may be in a different location relatively speaking on your new computer. So first try using the open option and select the project directly. If you continue to get this error message it generally means that the project file is damaged or corrupted. So something may have gone wrong when you copied it to the new computer. If you can get a fresh copy, try that.

If you only have the damaged version , you can check to see if there is anything inside the damaged file that you can save by changing its extension from .hmxz to .zip (it is actually a normal zip archive). You can then try to unpack it with a normal zip program or a zip repair tool. Frequently, however, anything more than minimal damage to a compressed archive will make the entire contents unreadable.

If you can't access the contents in this way you will have to return to your most recent backup. If you have activated the automatic backup option (View > Program Options > General) you may find a backup file with the extension .~~hmxz in your project folder. You can make this readable by changing the extension to .hmxz. Alternatively, you can generally recover your text by importing your last published output, if that is all you have available.

For important daily work we generally recommend using the uncompressed .hmxp format, if you have the Professional version of Help & Manual. In this format every topic and all the project files are saved as separate, plain-text XML files. Then damage to a single file cannot compromise your entire project, and since the files are plain text data can also be recovered from the undamaged portions of damaged files. You can convert .hmxz projects to .hmxp by selecting Save As... in the File menu. Uncompressed .hmxp projects must be saved to an empty folder initially, but you can add additional sub-folders to the project folder later if you like, for example for graphics etc.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

User avatar
Martin Wynne
Posts: 2604
Joined: Mon May 12, 2003 3:21 pm
Location: West of the Severn, UK

Re: Cannot load G:\. . . \ . . . .hmxz

Unread post by Martin Wynne » Fri May 13, 2016 12:56 pm

JeremyBelina wrote:The project file project.hmxp can not be found in archive C:\DephiXE6\ECS\EC\HMDAL.pas, line 6721
Hi Jeremy,

If you typed that line yourself, you made a typo -- DephiXE6 should be DelphiXE6

If you copied and pasted it from the actual message, something has gone very wrong.

regards,

Martin.

Debra Graham
Posts: 11
Joined: Wed May 23, 2018 10:30 pm

Re: Cannot load G:\. . . \ . . . .hmxz

Unread post by Debra Graham » Mon May 18, 2020 5:14 am

Hi, I am having the same problem, except it it an hmxp file that won't load. The file was on a network and I lost the connection and couldn't save the file. When I tried to reopen the file, I was asked if I wanted to load unsaved changes. I said yes, but the file would load and I got the Cannot load message:

Cannot load \\192.168.171.250\Documentation\PeerGFS
4.5.2 Help Manual - General
Availability\PeerGFSHelp.hmxp! Please ensure that you
have sufficient rights to open the project.
Could not open project file
\\192.168.171.250\Documentation\PeerGFS 4.5.2 Help
Manual - General Availability\PeerGFSHelp.hmxp.


I copied the project folder to my personal Documents folder but still no luck. I did check the _history folder and found this:

PeerGFSHelp.hmxp.~17D24668

The timestamp indicates it should contain my latest changes.

How can I resolve this problem?

Thanks,
Debra

User avatar
Tim Green
Site Admin
Posts: 21610
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Cannot load G:\. . . \ . . . .hmxz

Unread post by Tim Green » Mon May 18, 2020 8:05 am

Hi Debra,
I copied the project folder to my personal Documents folder but still no luck. I did check the _history folder and found this:

PeerGFSHelp.hmxp.~17D24668

The timestamp indicates it should contain my latest changes.
Move the (probably damaged) original .hmxp file to a save place just in case. Then copy the backup version from your history to the main project folder and change its extension to just .hmxp. That should fix it. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

Post Reply