Problem with SVN settings for Help and Manual project

This section is for announcements, information and discussions relating to the help community -- for example news about events and seminars of interest, developments in help technology and so on.

Moderator: Tim Green

Problem with SVN settings for Help and Manual project

Unread postby Sean Godley » Fri Aug 05, 2016 7:39 pm

Hi all,

I am having a problem with one of my help and manual projects. I know what the issue is but I do not know how to resolve it. It concerns the SVN directory. I do not know how to change the Subversion URL. At the moment it is classified as an svn+ssh and I need to change it to http. Any help hugely appreciated!

Thanks,

Sean
Sean Godley
 
Posts: 68
Joined: Sun Apr 24, 2016 6:10 am

Re: Problem with SVN settings for Help and Manual project

Unread postby Tim Green » Sat Aug 06, 2016 10:16 am

Hi Sean,

The easiest and safest thing to do here is simply download a fresh working copy from the server repository with the correct new credentials. Theoretically you could go into your project's .hmxp file manually and change the credentials there, but there is a possibility that could cause issues with the settings stored automatically in the .svn folder where Tortoise keeps everything.

If you then have changes in the old working copy not uploaded to the server that you need to propagate to the new working copy you can do that with a tool like the free WinMerge. Then you just compare the two instances of the .xml topic files and merge in your changes to the new working copy.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20619
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help Community & Resources

Who is online

Users browsing this forum: No registered users and 0 guests