Write - Search doesn't find things

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Write - Search doesn't find things

Unread postby Dave Gehman » Thu May 24, 2018 9:28 pm

I want to change toggle subheads from "See more...." to just "More...." However, when I use search and replace, I can make one S&R, then search fails to find any more instances, and I have toggles all through the project.

Results after clicking "Find Next" (the cursor had been placed at the top of the topic shown in the graphic below, so I would think search would find the instance that occurs one paragraph after the cursor position):

Image

Tried clicking on "Replace" and got this:

Image

How do I make S&R work through my entire project? There are dozens of "See mores" that should be "Mores"...
Dave Gehman
 
Posts: 252
Joined: Sat Sep 23, 2017 9:05 pm

Re: Write - Search doesn't find things

Unread postby Tim Green » Fri May 25, 2018 7:19 am

Hi Dave,

Where exactly is the text you are looking for? (Your first screenshot isn't displaying because it's no longer on Imgur.) If it is normal topic text the main reason for it not being found would be if part of it is formatted differently. It's a restriction of the editor that it can only search for text with contiguous formatting. For example, it won't find See more" if it is formatted See more (one word bold creates two different text blocks).

You also can't find any text that is part of the XML code and not displayed in the topic editor. And just to make absolutely sure (sorry if this is obvious): Do make sure that the scope of the search is set to "All Topics".
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19997
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Write - Search doesn't find things

Unread postby Dave Gehman » Fri May 25, 2018 8:58 am

Er... Imgur has changed its UI and seems to have forgotten tooltips or help... it lured me into posting the image on the "Community," which is a typical social-computing time-waster, exposes private information to the world, and doesn't seem to have a way to delete something once you accidentally put it there. As a result, I deleted the image and promptly forgot to re-upload it.

Anyway, here is the original image. Note that before I searched, I placed the cursor on the capital S of "Set Up Your Account":
Image

The search target is formatted as Tip Heading and is a toggle.

If S&R can't ignore formatting as it finds text, I won't try to use it from here on out.
Dave Gehman
 
Posts: 252
Joined: Sat Sep 23, 2017 9:05 pm

Re: Write - Search doesn't find things

Unread postby Tim Green » Fri May 25, 2018 9:50 am

Hi Dave,

Now that I can see your screenshot I was able to test it. There appears to be an issue here with searching for text in toggle headers. The text will be found if you use the current topic scope, but not with All Topics or All Topics from Here. We'll get onto it ASAP. Thanks for reporting this.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19997
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Write - Search doesn't find things

Unread postby Dave Gehman » Fri May 25, 2018 10:07 am

You're welcome. Meanwhile, Agent Ransack by Mythicsoft finds anything in an H+M project, but does't have the replace function. I'd forgotten I had it. Licensing is a bit confusing.
Dave Gehman
 
Posts: 252
Joined: Sat Sep 23, 2017 9:05 pm

Re: Write - Search doesn't find things

Unread postby Tim Green » Fri May 25, 2018 10:44 am

Dave Gehman wrote:You're welcome. Meanwhile, Agent Ransack by Mythicsoft finds anything in an H+M project, but does't have the replace function. I'd forgotten I had it. Licensing is a bit confusing.

If you have the Premium Pack add-on you can also use the included Toolbox power tools utility to search the source code of all your topics. It has five different search modes, including regular expressions. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19997
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Write - Search doesn't find things

Unread postby Dave Gehman » Fri May 25, 2018 1:57 pm

Tim Green wrote:If you have the Premium Pack add-on you can also use the included Toolbox power tools utility to search the source code of all your topics. It has five different search modes, including regular expressions. 8)


Yes, we have that add-on. I'll have to try that.

10 minutes later:
It took me some minutes to find it: It's 'Tools > Complex Find and Replace in Topics.' (Spent a lot of time going through the choices under Edit, which is where I gravitate when searching for Search in editors...)

I do wish it had a one-click or double-click to take me directly to the hit.
Dave Gehman
 
Posts: 252
Joined: Sat Sep 23, 2017 9:05 pm

Re: Write - Search doesn't find things

Unread postby Tim Green » Sat May 26, 2018 10:25 am

Dave Gehman wrote:I do wish it had a one-click or double-click to take me directly to the hit.

Thanks for the suggestion. The functions are currently focused on global processing of things in the source code rather than just finding things, but it's something I'll think about when working on updates. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19997
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Write - Search doesn't find things

Unread postby Tim Green » Mon Jun 18, 2018 8:48 am

Hi Dave,

Update: The text not being found in toggle headers is a quirk of the editor. To find it there, you need to change the search scope to "Captions" instead of "Topic text and header". The reason for this is that the entire topic is only available as plain text that can be searched when it is actually in the editor. That is why you can find it in toggle headers as well when the search is only in the current topic, because that is in the editor. When you search in multiple topics (all, or all from here) the search needs to be performed in the XML and that works differently. Then, at the moment at least, the search can either be performed in the normal XML elements or in the CDATA elements (captions), which are effectively outside of the normal XML.

That's a bit annoying, but unfortunately that's the way it works at the moment. I wasn't aware of this myself until now. :?
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19997
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 1 guest