Index of Images in Help Folders

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Index of Images in Help Folders

Unread postby Sean Godley » Mon May 28, 2018 10:45 am

Hi all,

I am wondering if there is a way to output an index of images contained in projects? I have created 20+ manuals and I am certain that many of their folders contain images that are no longer published in the output formats. It would be very useful to view an index/breakdown of images contained in the folders. Is there a way to do this?

Thanks,

Sean
Sean Godley
 
Posts: 66
Joined: Sun Apr 24, 2016 6:10 am

Re: Index of Images in Help Folders

Unread postby Tim Green » Mon May 28, 2018 11:54 am

Hi Sean,

Select Project > Report Tool and then select the Full Report option. You will get a list of all pictures, missing pictures and unused pictures, and the option to move the unused pictures to another folder. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20172
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Index of Images in Help Folders

Unread postby Sean Godley » Wed May 30, 2018 11:54 am

Fantastic - that will save on space massively. Thanks a million!

Sean
Sean Godley
 
Posts: 66
Joined: Sun Apr 24, 2016 6:10 am

Re: Index of Images in Help Folders

Unread postby Sean Godley » Mon Aug 20, 2018 3:20 pm

Hi Tim - just to get back to you on this one, after I create the tool report that details unused images, and then I click 'move unused images from this folder to a backup folder' I encounter errors and H&M tells me that the 'source image was not found' - yet it is immediately after I have done the search - so presumably the images are there?

I'd really appreciate any light you could shed on this.

Thanks,

Sean
Sean Godley
 
Posts: 66
Joined: Sun Apr 24, 2016 6:10 am

Re: Index of Images in Help Folders

Unread postby Tim Green » Wed Aug 22, 2018 6:24 am

Hi Sean,

The most likely cause there is that you have not updated Help+Manual recently. That is an issue that was fixed relatively recently. Check your current build with help about then go to the installer download page here to see if the current version is newer:

https://www.helpandmanual.com/downloads.html?upd
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20172
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Index of Images in Help Folders

Unread postby Sean Godley » Wed Aug 22, 2018 3:41 pm

Hi Tim,

I updated to the latest version but I am still experiencing the same issues. Is there anything else that might be causing them?
Sean Godley
 
Posts: 66
Joined: Sun Apr 24, 2016 6:10 am

Re: Index of Images in Help Folders

Unread postby Tim Green » Thu Aug 23, 2018 8:57 am

Sean Godley wrote:I updated to the latest version but I am still experiencing the same issues. Is there anything else that might be causing them?

Anything strange in the names of your images? Spaces, accented characters, non-Latin characters, particularly, long names, names starting with a number, anything like that?
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20172
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Index of Images in Help Folders

Unread postby Sean Godley » Thu Aug 23, 2018 10:58 am

Hi Tim - I discovered what the issue is and I'll post the details here as it may help others with the same problem in the future. After creating more than twenty long manuals for my company, there were thousands upon thousands of image files to maintain. During the creation of these image files for the manuals, some of them were saved with accidental commas in their names. When I checked the files that were problematic, it was a file that contains a comma in its filename. After removing these files manually, one at a time, as they were identified as problematic in the tool report (I.e. they were the files that resulted in the error message) the remove images feature worked fine and I am happy to report that I have massively cleaned up my manual folders as a result of the process. I assume that the "Move images to backup folder feature" lists files using commas as delimiters, or something similar, and that therefore the very occasional comma type resulted in the error message. It was confusing to begin with, as this feature would move some files to the backup folder but then break down when it reached a filename that contained a comma - only after this happening multiple times did it become clear what the cause of the issue was. I'd recommend adding some text to the error message that says something along the lines of "please ensure that filenames do not contain these characters" and a list of problematic characters. It would have saved me a bit of head scratching anyway!

In any case, as mentioned, I am very happy that I have been able to remove these files from my project folder and very impressed with the overall dynamics and wizardry of Help and Manual.

Cheers,

Sean
Sean Godley
 
Posts: 66
Joined: Sun Apr 24, 2016 6:10 am

Re: Index of Images in Help Folders

Unread postby Tim Green » Thu Aug 23, 2018 11:07 am

Hi Sean,

Thanks for the feedback. I'm passing this on to our developers for checking and possible mitigation for future releases. :)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20172
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Index of Images in Help Folders

Unread postby Sean Godley » Fri Aug 24, 2018 9:46 am

Great - glad to assist you.

Cheers,

Sean
Sean Godley
 
Posts: 66
Joined: Sun Apr 24, 2016 6:10 am

Re: Index of Images in Help Folders

Unread postby Tim Green » Wed Aug 29, 2018 12:59 pm

Update: This has now been corrected. When 7.4 is released commas in image filenames will no longer throw the move unused files function off. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20172
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 8 guests