Unusual - lost a lot of work

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Unusual - lost a lot of work

Unread postby Dave Gehman » Wed Jun 13, 2018 5:42 pm

I appear to have lost a lot of work in one topic. There was no prompt to restore when opening H+M.

In the project's _history folder there appear to be backups for all of the topics (they have to do with an integration with Autodesk Revit) - the files in the light blue shading below:

Image

It looks as though the file indicated by the arrow has the most promise: KnowledgeBridgeHelp-09May2018.hmxp~0008A983 but I cannot find a way to access it.

Failing that, all the history files that reference Revit will probably help, but again, I cannot find a way to access them.

Is there a way to retrieve these?
Dave Gehman
 
Posts: 253
Joined: Sat Sep 23, 2017 9:05 pm

It healed itself ! was: Re: Unusual - lost a lot of work

Unread postby Dave Gehman » Wed Jun 13, 2018 6:16 pm

Windows 10 apparently lost its mind temporarily. After I scrambled through my backup files -- and not actually setting off a recovery -- and closing a bunch of open windows, the topics are back.

For a period of about 6 hours today, however, H+M displayed help unit in question as if it had inexplicably reverted to the state it was in 2 days ago.

Could this be a sign of impending instability in my project?

If instability is in my future -- in this project, I mean -- it's pretty certainly in my future in life -- what's the best way to avoid this doom?
Dave Gehman
 
Posts: 253
Joined: Sat Sep 23, 2017 9:05 pm

Re: Unusual - lost a lot of work

Unread postby Tim Green » Thu Jun 14, 2018 8:51 am

Hi Dave,

This sounds a little odd. Two questions:

  • Are you using uncompressed .hmxp or single-file .hmxz?
  • Is your project stored and accessed on a network drive or locally?

It definitely shouldn't be anything to do with your project directly. It all sounds much more like some external problem in the Windows file system. I ask about the network connection because it sounds as though this might be some kind of strange cache phenomenon. That could also happen locally, but it would be more likely on a network connection. It would happen if your system was set up to delay writes to disk and/or if the network connection was a little unreliable, so that you were not always getting the data.

Generally, you should always be able to access the previous versions directly from within the project with the history function. Just click on the gear icon in the top left corner of the editor window and select Show History. Then you can choose which topic version you want to revert to. Failing that, if the project is uncompressed, you can always access the contents of any history topic backup like this:

  1. Copy the topic file from the history to another folder and change its extension to plain .xml.
  2. Create a new empty topic and load the source from step 1 into it with File > Load topic from file in the Project > Manage Topics tab.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19997
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Unusual - lost a lot of work

Unread postby Dave Gehman » Thu Jun 14, 2018 12:28 pm

Tim Green wrote:
  • Are you using uncompressed .hmxp or single-file .hmxz?
  • Is your project stored and accessed on a network drive or locally?


Uncompressed .hmxp and stored locally.

It definitely shouldn't be anything to do with your project directly. It all sounds much more like some external problem in the Windows file system.


Actually, while I thought it was unrelated, earlier in the day, Explorer froze and I had to kill and restart it... apparently, not unrelated at all.

Generally, you should always be able to access the previous versions directly from within the project with the history function. Just click on the gear icon in the top left corner of the editor window and select Show History.


I don't have a gear icon in top left, but now, I sure would like something that gets me directly to the history. There's a gear icon in the Project tab, but that's for properties, templates and options. (I have checked all the Configuration > Miscellaneous > XML Topic FIles boxes that have to do with history. )

Is there perhaps an updated method to obtain that icon, one that's not yet in the help file?
Dave Gehman
 
Posts: 253
Joined: Sat Sep 23, 2017 9:05 pm

Re: Unusual - lost a lot of work

Unread postby Tim Green » Thu Jun 14, 2018 3:48 pm

Hie Dave,

Dave Gehman wrote:I don't have a gear icon in top left, but now, I sure would like something that gets me directly to the history.

I think you may be looking in the wrong place. It's not in the toolbar, it's in the top left corner of the editor window itself:

GearIcon.jpg
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 19997
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Unusual - lost a lot of work

Unread postby Dave Gehman » Thu Jun 14, 2018 4:51 pm

While I was searching for the gear, I was in the Table of Contents in the Project Explorer where it does not appear. Once I knew exactly where to look, a quick experiment (clicking on a topic further down the tree) revealed the icon...

Thanks.
Dave Gehman
 
Posts: 253
Joined: Sat Sep 23, 2017 9:05 pm


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 1 guest