Safari browser loads help and will repeatedly refresh itself

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Safari browser loads help and will repeatedly refresh itself

Unread postby Mike Law » Wed Jun 20, 2018 2:47 pm

Admittedly this is a weird one.

Using HM 7.3.4 and I think Premium Pack 2.72.

In our software we include an option for offline/local access to help files because some of our users are behind firewalls and don't have access to the same files we host on the web. If their default browser is Safari, we have noticed that when the index.html file loads, it will repeatedly refresh the browser window.

Have you guys encountered anything like this before?

Thanks!
Mike Law
 
Posts: 9
Joined: Wed Feb 04, 2015 11:30 pm

Re: Safari browser loads help and will repeatedly refresh it

Unread postby Tim Green » Wed Jun 20, 2018 4:12 pm

Hi Mike,

Have you guys encountered anything like this before?

No, but if you are using Help+Manual 7 you should be on Premium Pack 3. The skins in the version 2.x package are not fully compatible with the HTML generated by HM7. If you continue to have problems with the current version mail me a demo project and your skin at support AT ec-software.com (replace the AT with @) and I'll check it for you.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20203
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Safari browser loads help and will repeatedly refresh it

Unread postby Mike Law » Tue Jun 26, 2018 3:33 pm

Thank you Tim. Sent an email this morning with some demo files.
Mike Law
 
Posts: 9
Joined: Wed Feb 04, 2015 11:30 pm

Re: Safari browser loads help and will repeatedly refresh it

Unread postby Tim Green » Wed Jun 27, 2018 6:46 am

Update: Thanks for the files. The issue is related to opening the WebHelp without a web server, which does not work any more. Like most other current browsers, Safari blocks communication between the iFrames needed to display multiple pages in a single page in WebHelp (TOC, index, search and topic) when they are not on a web server. Everything works fine once it is accessed on a server.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20203
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 8 guests

cron