EBook Issues

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

EBook Issues

Unread postby Sue King » Wed Jul 04, 2018 1:52 am

Hi,

I'm using EBooks for my product help. Recently re-testing it in my project, I've found a couple of issues, one which I could resolve, and one which needed a work around.

There is a ebook.exe in Program Files x86, with an ebook.pebk in the application documents help folder. (I have changed the ebook default extension).
The ebook.exe is spawned using Create Process, not Shell execute.

The first problem was that help was not closing properly when the application closed. I was spawning ebook.exe with the 'close' as a command line parameter. I found I needed to add the name of the ebook as well to the command line so that it was 'ebook.pebk close'. This seems pretty obvious but from the example in a post some time ago using, the ebook name was not included, )possibly because the exe and data were not separate). I mention this in case someone else comes across it in future, as I can't see it documented anywhere else. (I may just have missed it).

The second problem is that spawning help using 'index.html' as a parameter caused the ebook.exe to take about 25% CPU (on my test PC) and never display. Attempts to close it programmatically failed. That is, starting with a command line with 'bookfile index.html'.

With further testing, for me any way, I found the following success/failure combinations.
1. Program : 'C:\Program Files ..\ebook.exe'; Cmdline: C:\Documents\ .. \ebook.pebk index.html' Opens the index on Win10 Build 1709
2. Program : 'C:\Program Files ..\ebook.exe'; Cmdline: C:\Documents\ .. \ebook.pebk index.html' Starts but never displays Win10 Build 1803
3. Program : 'C:\Program Files ..\ebook.exe'; Cmdline: C:\Documents\ .. \ebook.pebk' No parameter for topic, opens the index on Win10 Build 1803
4. Program : 'C:\Program Files ..\ebook.exe'; Cmdline: C:\Documents\ .. \ebook.pebk 0' Starts but never displays Win10 Build 1803
5. Program : 'C:\Program Files ..\ebook.exe'; Cmdline: C:\Documents\ .. \ebook.pebk 0' Opens with topic not found on Win10 Build 1709
6. Program : 'C:\Program Files ..\ebook.exe'; Cmdline: C:\Documents\ .. \ebook.pebk 106' Opens topic 106 Win10 Build 1803 and 1709
7. Program : 'ebook.exe'; Cmdline: C:\Documents\ .. \ebook.pebk index.html' Opens the index on Win10 Build 1803 and 1709 (possible since the application starting the ebook is in the same folder as ebook.exe)

I suspect that the blanks in the path when the exe is in Program files might be contributing to the problem, but it is a guess.

I can work around the issue for now, given that there are ways to open the file correctly. However I thought this might be something that needs further investigation as other may find that their ebooks are no longer opening properly as Win10 Build 1803 is rolled out.

Hope this helps someone,

Sue
Sue King
 
Posts: 19
Joined: Tue Jul 26, 2011 9:12 pm

Re: EBook Issues

Unread postby Sue King » Wed Jul 04, 2018 6:40 am

I've done some more testing with this and it's getting weirder.

Using the same test program on Win 10 build 1709 and 1803, it appears that the results above are not entirely correct.

What works every time on build 1709, works on every second attempt to open help on build 1803, starting by not showing and CPU to 25% when it doesn't work.

So my work around didn't help, and some of the success/failure for 1803 depended on whether it was an even or odd attempt to open the help.

Any ideas anyone ?

TIA

Sue
Sue King
 
Posts: 19
Joined: Tue Jul 26, 2011 9:12 pm

Re: EBook Issues

Unread postby Tim Green » Wed Jul 04, 2018 7:29 am

Hi Sue,

Before we get on to anything else, what version and build of Help+Manual are you using? You can check with Help > About. The current version is 7.3.6 Build 4521. There were some issues with EWriter books that were fixed a while ago and your issues sound as though they may be related. That being said, Windows 10 1803 is still a hot mess of pain and sorrow and we have rolled it back to 1709.

Also, are you always enclosing your arguments in double quotes, even if they don't contain spaces? This is necessary to stop poor Forrest Windows from getting confused about other characters as well.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20043
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: EBook Issues

Unread postby Sue King » Wed Jul 04, 2018 8:02 am

Hi Tim,

Hmm, I'm not on the latest, by bad and possibly a day wasted :( . I thought I was as I always try to update when I get notification of an update. I'm still on 7.34, although I had downloaded 7.35. I'll update and re-test.

I did try with the double quotes but found it made no difference.

Thanks

Sue
Sue King
 
Posts: 19
Joined: Tue Jul 26, 2011 9:12 pm

Re: EBook Issues

Unread postby Sue King » Wed Jul 04, 2018 8:19 am

Hi Tim,

There is no change. Now running 7.36.4521.

There is also a problem double clicking on the ebook.pebk. Every second attempt to open it succeeds. The others fail.

Also if I double click on the exe, every second attempt to run the exe succeeds.

The test PC is Windows Home. The client has Windows Pro for the same Version. Maybe I'll just disable the help for now - the client probably doesn't use it.

Sue
Sue King
 
Posts: 19
Joined: Tue Jul 26, 2011 9:12 pm

Re: EBook Issues

Unread postby Tim Green » Wed Jul 04, 2018 8:22 am

Hi Sue,

Thanks for the details. We'll look into this right away and I may ask you for a demo project.

Maybe I'll just disable the help for now - the client probably doesn't use it.

Er...no. This should work. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20043
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: EBook Issues

Unread postby Tim Green » Wed Jul 04, 2018 9:21 am

Hi Sue,

I've just tested this thoroughly on Windows 10 1709 and 1803 and I can't reproduce any problems. Looking carefully at your posts I think the problem may be in the formatting of your command lines:

Code: Select all
Cmdline: C:\Documents\ .. \ebook.pebk index.html'

It's not complete, but it looks as though you could be doing this:

Code: Select all
"...viewer.exe" "...ebook.pebk index.html"

If that's the case, it's wrong. You need to have three separate arguments on the line, each enclosed in quotes. It should be:

Code: Select all
"...viewer.exe" "..ebook.pebk" "index.html"

with the "index.html?topic.htm" part separate, as its own quoted argument.

This still doesn't explain why you're getting problems with double-clicking on the book file. To be able to check that we need to look at your viewer and your book. Please pack the following into a zip and provide a download link (mailing it won't work with .exe files in the zip):

  • A small demo version of your .pebk book that reproduces the problem.
  • Your .exe book viewer.
  • The demo project used to create your demo book, preferably as an .hmxz
  • The .hmskin file used to create your viewer and your book.
Mail the download link to support AT ec-software.com (replace the AT with @) with a reference to this thread on the forum. :)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20043
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: EBook Issues

Unread postby Alexander Halser » Wed Jul 04, 2018 10:02 am

Hi Sue,

Can you please try the cases that do not work repeated times?
The ebook instantiates a local webserver instance and it sometimes takes longer until this local webserver is ready to deliver. I think this is the case here. It just takes longer for the local server to respond.
Alexander Halser
Senior Software Architect, EC Software GmbH
User avatar
Alexander Halser
EC-Software Support
 
Posts: 3810
Joined: Mon Jun 24, 2002 7:24 pm
Location: Salzburg, Austria

Re: EBook Issues

Unread postby Sue King » Thu Jul 05, 2018 3:08 am

re : Formatting of the command lines

I agree that when you use shell commands the double quotes are often needed. I'm not so sure that this is the case with CreateProcess when there are no embedded blanks. I've been using CreateProcess for a long time without double quotes, and have not had any issues when the parameters don't contain blanks. I was using the double quotes in some tests, but dropped them when they didn't appear to have any impact on results.

re : Repeating tests

Each of the tests were repeated at least 4 times to establish the pattern. Currently, I am mostly testing with the small ebook.exe, as I have reached the conclusion that the parameters are irrelevant.

With further testing, I have found that the issue is related to my PC. I tested the ebook on another Version 1803 PC, and it works as it should. Looking at what is running, there is nothing newly installed since the upgrade to 1803 that I can see. I did have another problem on startup with an error 'There was a problem starting C:\Program.' This was fixed after consulting Mr Google and adjusting a couple of registry entries.

The PC is a Lenovo Thinkpad E520, a few years old now, but seems to work for most things I ask of it.

I've tried disabling anti-virus (eset), automatic backups, One drive, password utility, all with no effect.

The actual ebook.exe is a very small project with title set and copyright set and a skin from the premium pack. I created a new ebook project with no topics, no changes, no skin, and it also fails in the same way.

When I start an exe that doesn't show, and then start another exe, the second one doesn't communicate with the first one running and starts up OK, although slightly more slowly than if the first one has been killed through task manager. Subsequent calls to different topics then work correctly. However if I close the working one, and try to open another instance, I get a second one that fails to display. The instance that fails to show ends up at 25% CPU, as though it is looping. I had three running at 25% at one stage, but didn't push it past that.

It seems that the only way to get to the bottom of the issue is for you to give me some tips on how to trace through what is happening on my machine, or send me a debug version of an ebook with some logging that might show what is going on. If you think this is worthwhile, I will do what I can to help get to the bottom of the problem.

I doubt that you will be able to see much from my project as the issue seems to be local to my PC, and affects an ebook with nothing added to the default project. I can send the basic one if you still think it would help.

I think I will try distributing the files and check the client when they are installed to make sure all is OK.

Sue
Sue King
 
Posts: 19
Joined: Tue Jul 26, 2011 9:12 pm

Re: EBook Issues

Unread postby Alexander Halser » Thu Jul 05, 2018 6:15 am

Hello Sue,

Please create the ebook (ebook.pebk) in debug mode. The H&M ebooks have this option on board already:

Clip1.gif


This will tell you what happens when the ebook starts, but displays the wrong page.

If the ebook viewer does not show its viewer window at all, it is a different problem, that does not have anything to do with the internal file structure of the ebook. Please check the debug mode first, and if it still doesn't work, send the ebook.exe and the ebook data to support @ ec-software.com to analyze it.
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
Alexander Halser
Senior Software Architect, EC Software GmbH
User avatar
Alexander Halser
EC-Software Support
 
Posts: 3810
Joined: Mon Jun 24, 2002 7:24 pm
Location: Salzburg, Austria

Re: EBook Issues

Unread postby Sue King » Thu Jul 05, 2018 6:43 am

Hello Alexander,

The ebook doesn't open every second time. I've sent an email with screens of the ebook running under 1709 and 1803 (when it does open). The log is a bit different.

I have also included the ebook. There is no data.

Thanks for looking into this,

Sue
Sue King
 
Posts: 19
Joined: Tue Jul 26, 2011 9:12 pm

Re: EBook Issues

Unread postby Sue King » Fri Jul 06, 2018 2:51 am

Hi,

For anyone reading this, it turns out the issue is that the ebook.exe is not code signed and it looks as though there are some security settings upsetting it.

A test viewer that has been code signed works fine on my PC when run from the same folder in program files that the application is installed into.

Sue
Sue King
 
Posts: 19
Joined: Tue Jul 26, 2011 9:12 pm


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron