custombuilds attribute of a project's config-group node

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

custombuilds attribute of a project's config-group node

Unread postby julio » Wed Jul 18, 2018 2:40 pm

I have some questions about the internal structure of .hmxp files:
The document Helpman_XML_Ref.chm states that the config-group node with a name attribute configured as "project" can contain a config-group node with a name attribute configured as "custombuilds" (all lower case). This is the node storing all custom builds for a project. After creating a new project in H&M 7.3, this attribute is configured as "CUSTOMBUILDS" (all upper case). I believe H&M internally does not care about this difference in names but I am developing a tool to automatically check for custom builds in projects and this tool uses Microsoft's XML implementation. This implementation differentiates lower and upper case names, so my tool fails to retrieve custom builds from projects created recently. Projects created with older versions keep their lower case versions when opened in newer versions.
My questions are: When this started to happen? The upper case version is now the official value for this attribute and the reference document is wrong?

Thank you.
User avatar
julio
 
Posts: 91
Joined: Wed May 28, 2008 12:06 am
Location: Porto Alegre, RS - Brasil

Re: custombuilds attribute of a project's config-group node

Unread postby Tim Green » Wed Jul 18, 2018 4:18 pm

Hi Julio,

Yes, there have been some changes with this over time, I've noticed that too. Help+Manual definitely doesn't mind about the case. I've asked Alexander to comment on the current status.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20251
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: custombuilds attribute of a project's config-group node

Unread postby Tim Green » Thu Jul 19, 2018 1:46 pm

Hi Julio,

Update: This was caused by some internal changes and will be fixed in the next update. However, if you manually edit the CUSTOMBUILDS name in the project to custombuilds Help+Manual will accept it and will not change it, so you can do that to fix it for yourself now. The difference over time was caused by the fact that the default project template no longer contains a custombuilds node. In earlier versions it already contained one, and when a NEW one was added then it was created with an upper case name (which also worked because the processing is not case-sensitive). That will now be changed. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20251
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: custombuilds attribute of a project's config-group node

Unread postby julio » Thu Jul 19, 2018 2:49 pm

OK, thanks. I am using an XPath query like that:

Code: Select all
//config/config-group[@name='project']/config-group[@name='custombuilds' or @name='CUSTOMBUILDS']/config-value


and is working fine, as long as you don't change this attribute to something else :D

Tim Green wrote:Hi Julio,

Update: This was caused by some internal changes and will be fixed in the next update. However, if you manually edit the CUSTOMBUILDS name in the project to custombuilds Help+Manual will accept it and will not change it, so you can do that to fix it for yourself now. The difference over time was caused by the fact that the default project template no longer contains a custombuilds node. In earlier versions it already contained one, and when a NEW one was added then it was created with an upper case name (which also worked because the processing is not case-sensitive). That will now be changed. 8)
User avatar
julio
 
Posts: 91
Joined: Wed May 28, 2008 12:06 am
Location: Porto Alegre, RS - Brasil

Re: custombuilds attribute of a project's config-group node

Unread postby Tim Green » Fri Jul 20, 2018 8:16 am

julio wrote:and is working fine, as long as you don't change this attribute to something else

Don't worry, we would never change something like that. We'd get murdered... :twisted:
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20251
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 10 guests

cron