Version of JQuery used in generated help with Premium Pack

This forum is for discussions on the Help & Manual Premium Pack and the Premium Pack Toolbox configuration utility introduced with Premium Pack 3

Moderators: Alexander Halser, Tim Green

Version of JQuery used in generated help with Premium Pack

Unread postby Sonia Guimond » Fri Jan 25, 2019 9:09 pm

Hi,
Our company implements vulnerability testing that revealed that the help system I generate uses a script library named JQuery version 2.14.
We were recommended to update to a version 2.2.0 (or later) of JQuery.
I generate online help (Web help format) by using the premium pack 3.46. I use the skin “Minimalist_Blue_Diamond” with a few customizations. I use version 7.4.1 build 4615 of Help & Manual.
Is there a way I can ensure the help system uses a version 2.2.0 (or later) of JQuery? I have read on the forum that a maintenance update of Premium Pack is available. If I were to install this maintenance update would this ensure that a later version of JQuery is used in our help system?
If you need extra information, please let me know.
Regards,
Sonia Guimond
Sonia Guimond
 
Posts: 60
Joined: Fri Oct 27, 2006 7:16 pm

Re: Version of JQuery used in generated help with Premium Pa

Unread postby Tim Green » Sat Jan 26, 2019 10:36 am

Hi Sonia,

No problem, the current version of the Premium Pack implements jQuery 2.2.4. 8)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20823
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Version of JQuery used in generated help with Premium Pa

Unread postby Sonia Guimond » Sun Jan 27, 2019 8:19 pm

Hi Tim,

Thanks for the prompt reply. I'll make sure to install the latest version of Premium Pack.

Regards,
Sonia Guimond
Sonia Guimond
 
Posts: 60
Joined: Fri Oct 27, 2006 7:16 pm

Re: Version of JQuery used in generated help with Premium Pa

Unread postby Sonia Guimond » Tue Feb 26, 2019 6:50 pm

Hi Tim,
I installed the latest version of the Premium Pack, updated the skins and rebuild the help. The jQuery is now at 2.2.4.
When the vulnerability tests are run on the rebuilt version of the help system, we are told it would be safer to have a version of jQuery that is later than 3.
Are there any plans to upgrade the Premium Pack to version 3.3.1 of jQuery?
Regards,
Sonia
Sonia Guimond
 
Posts: 60
Joined: Fri Oct 27, 2006 7:16 pm

Re: Version of JQuery used in generated help with Premium Pa

Unread postby Tim Green » Wed Feb 27, 2019 7:41 am

Hi Sonia,

We've been sticking to 2.2.4 out of an excess of caution because of people still using older browsers that jQuery 3.x doesn't support. However, you can upgrade a skin yourself very easily: Just download the current minified (compressed) version of jQuery from here:

https://jquery.com/download/

Change its name to jquery.js and load it into the baggage of your skin, replacing the version there. That's all there is to it. :)
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20823
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany


Return to Premium Pack and PP Toolbox

Who is online

Users browsing this forum: No registered users and 2 guests