Random crash on startup

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Random crash on startup

Unread postby rossmcm » Wed Feb 13, 2019 9:11 pm

Running most recent update (4650) on Win10 Home.

Every now and again I get the following crash on starting H&M (this invocation was from a batch file but I've seen it on starting the IDE also):

H&M5.png

On dismissing this I get:

H&M6.png

The PC has 16G of RAM and is lightly loaded - plenty of spare memory showing (although H&M being a 32-bit application is probably limited by that).

Any comments appreciated. It's a bummer when it occurs in a batch build and I don't notice it for a while.
You do not have the required permissions to view the files attached to this post. This may mean that you can't view them at all, or it may just mean that you need to log into the forum to view them.
rossmcm
 
Posts: 49
Joined: Sun Nov 11, 2007 10:57 pm
Location: New Zealand (Auckland)

Re: Random crash on startup

Unread postby Tim Green » Thu Feb 14, 2019 7:24 am

Hi Ross,

This isn't currently a known error. I've passed it on to our developers and will let you know what they say. If you get a dialog asking you to submit an error report when this happens please do send it because it will include the necessary analysis information.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.
User avatar
Tim Green
Site Admin
 
Posts: 20535
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany

Re: Random crash on startup

Unread postby Alexander Halser » Thu Feb 14, 2019 10:20 am

Hello Ross,

Is Help+Manual locally installed or is it a server version? If the failures are occasional, it could be a network problem. The file reported is a DLL that is used by the main application. It implements the syntax highlighter for code examples.
Alexander Halser
Senior Software Architect, EC Software GmbH
User avatar
Alexander Halser
EC-Software Support
 
Posts: 3875
Joined: Mon Jun 24, 2002 7:24 pm
Location: Salzburg, Austria

Re: Random crash on startup

Unread postby rossmcm » Thu Feb 14, 2019 11:01 am

It is locally installed. The crash happens way before the UI gets started (i.e. there is no project loaded, so no syntax to highlight).

Previously when it has occurred I have been able to try again and it would start up and run without a problem, but I tried it just now and it consistently faults.
rossmcm
 
Posts: 49
Joined: Sun Nov 11, 2007 10:57 pm
Location: New Zealand (Auckland)

Re: Random crash on startup

Unread postby rossmcm » Thu Feb 14, 2019 11:04 am

...and now it is working fine!

Is there a command-line option I can use to get a startup log?
rossmcm
 
Posts: 49
Joined: Sun Nov 11, 2007 10:57 pm
Location: New Zealand (Auckland)

Re: Random crash on startup

Unread postby Alexander Halser » Thu Feb 14, 2019 11:22 am

This happens at application initialization, way too early even for a startup log. That's why you get a plain error message, and no bug report.

Can you try to copy the Help+Manual installation folder to a new place and start HELPMAN.EXE from that folder? You can simply copy the entire installation folder of H&M including subfolders. It will run as long as it is on the same PC.
Alexander Halser
Senior Software Architect, EC Software GmbH
User avatar
Alexander Halser
EC-Software Support
 
Posts: 3875
Joined: Mon Jun 24, 2002 7:24 pm
Location: Salzburg, Austria


Return to Help & Manual 7 Forum

Who is online

Users browsing this forum: No registered users and 11 guests