Javascript Error with Built CHM

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Post Reply
User avatar
cindynotbrady
Posts: 156
Joined: Wed Mar 01, 2006 3:49 pm
Location: Provo, Utah

Javascript Error with Built CHM

Unread post by cindynotbrady » Thu Mar 05, 2020 8:15 pm

For one of our files, we keep getting a weird Script Error (see below). We've tried publishing the CHM with a newer, better skin. We've tried publishing with no skin, and we still get the error. Have you seen this? We've been combing through the topics, and we can't see why this is happening.

Here is the error in print format in case someone wants to search for it in the Forum:

"An error has occurred in the script on this page.

Line: 385 Char: 5

Error: Unable to get property 'setAttribute' of undefined or null reference

Code: 0

URL mk@MSITStore:C:\.....

See below:
scripterror.png
You do not have the required permissions to view the files attached to this post.

User avatar
cindynotbrady
Posts: 156
Joined: Wed Mar 01, 2006 3:49 pm
Location: Provo, Utah

Re: Javascript Error with Built CHM

Unread post by cindynotbrady » Thu Mar 05, 2020 8:23 pm

Nevermind. It looks like we had a faulty bitmap image or our links were corrupted. We fixed those and the error went away.

User avatar
cindynotbrady
Posts: 156
Joined: Wed Mar 01, 2006 3:49 pm
Location: Provo, Utah

Re: Javascript Error with Built CHM

Unread post by cindynotbrady » Mon Mar 09, 2020 10:43 pm

Just for future reference, I usually get this error when it's a faulty toggle. Or there is a keyword in a toggle that has a pound sign (hashtag). (Does "pound sign" show my age.) :D

Post Reply