Need Help Restoring Syntax Highlighting

Please post all questions on Help+Manual 8 here

Moderators: Alexander Halser, Tim Green

Post Reply
User avatar
Olivier Beltrami
Posts: 304
Joined: Mon Jul 15, 2002 3:30 pm
Location: Nantes, France
Contact:

Need Help Restoring Syntax Highlighting

Unread post by Olivier Beltrami » Mon Mar 16, 2020 7:24 pm

Hi,

I recently moved from HM7 to HM8 as well as migrating from Win7 to Win10 (clean re-install).

The source code style sheet I was using in my main project carried over with my project, but I cannot find the special custom highlighting that was part of my project. An example of the formatting can be seen at https://www.qppstudio.net/webhelp_xv4/h ... ondate.htm.

The existing samples are all OK, but I cannot apply this formatting to new examples. The custom syntax highlighting seems to have disappeared from the project. Do you know how if I can find it again ? (please tell me it was not lost in the migration)

Very best regards,

Olivier
Olivier Beltrami
https://www.qppstudio.net
Worldwide Public Holidays and Calendar Data

User avatar
Tim Green
Site Admin
Posts: 21493
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Need Help Restoring Syntax Highlighting

Unread post by Tim Green » Tue Mar 17, 2020 8:12 am

Hi Olivier,

The syntax highlighting settings are program settings, not project settings. They're stored in the Windows Registry for the program, in HKCU > Software > ECSOFTWARE > Help & Manual X > SyntaxHighlight. I'm checking whether it's possible or safe to copy the keys for the custom highlighting information manually from the HM7 branch to the HM8 branch. I'll let you know.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

User avatar
Alexander Halser
EC-Software Support
Posts: 3975
Joined: Mon Jun 24, 2002 7:24 pm
Location: Salzburg, Austria
Contact:

Re: Need Help Restoring Syntax Highlighting

Unread post by Alexander Halser » Tue Mar 17, 2020 8:19 am

Hi Olivier,
I think the first release of v8.0 did not copy the highlighting settings from version 7, but the current version does. However, if HM8 has been started once, it has stored its own registry setting for highlighting and this one takes priority.

Please close HM8, open the Windows registry editor and navigate to

HKEY_CURRENT_USER\Software\ECSOFTWARE\Help+Manual 8

Delete the entire branch "SyntaxHighlight" with all sub-entries.
Start Help+Manual 8 again and open the syntax highlighter configuration. It should have picked up all the settings from version 7.
Alexander Halser
Senior Software Architect, EC Software GmbH

User avatar
Olivier Beltrami
Posts: 304
Joined: Mon Jul 15, 2002 3:30 pm
Location: Nantes, France
Contact:

Re: Need Help Restoring Syntax Highlighting

Unread post by Olivier Beltrami » Tue Mar 17, 2020 9:38 am

Thank you very much, Tim and Alexander.

Unfortunately, I did a clean install of Windows 10, and did not realize that these settings were saved outside of my project. :cry:
I'll just have to re-create them. :typing:

Very best regards,

Olivier
Olivier Beltrami
https://www.qppstudio.net
Worldwide Public Holidays and Calendar Data

Post Reply