Problem with link to PDF file

Please post all questions and comments regarding Help & Manual 7 here.

Moderators: Alexander Halser, Tim Green

Post Reply
mbgg
Posts: 120
Joined: Sun Oct 22, 2006 3:42 pm

Problem with link to PDF file

Unread post by mbgg » Mon May 18, 2020 9:02 am

Hi-
I want to link to a PDF file from my CHM help.
- I create the link with the [File link] tab in the Insert Link option
- the PDF file is displayed when I click on [Test}
- I then [Publish] the CHM file. When the window with the Help opens up I click on the link and the PDF is displayed.
- I then copy both the CHM file and the PDF file to my program directory. I start the program, click [Help]-> [Contents] and navigate to the topic. Nothing happens when I click on the link.

Any suggestions? :frustration:

Michael
Michael

Version 7.3.0 - Build 4180

User avatar
Tim Green
Site Admin
Posts: 21624
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Problem with link to PDF file

Unread post by Tim Green » Mon May 18, 2020 9:39 am

Hi Michael,

What is the name of the PDF file? Does it contain spaces, special characters, accented characters etc? All those things can be a problem for the ancient CHM system (well, actually for anything involving HTML). Also, which CHM skin are you using?
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

mbgg
Posts: 120
Joined: Sun Oct 22, 2006 3:42 pm

Re: Problem with link to PDF file

Unread post by mbgg » Mon May 18, 2020 10:15 am

I'm using the same skin as yesterday: "CHM skin, dark blue header ..."
The file name is all letters and numbers, no characters, underscores, etc
Michael

Version 7.3.0 - Build 4180

User avatar
Tim Green
Site Admin
Posts: 21624
Joined: Mon Jun 24, 2002 9:11 am
Location: Bruehl, Germany
Contact:

Re: Problem with link to PDF file

Unread post by Tim Green » Mon May 18, 2020 12:47 pm

Hi Michael,
- I then copy both the CHM file and the PDF file to my program directory. I start the program, click [Help]-> [Contents] and navigate to the topic. Nothing happens when I click on the link.
This may be a permissions issue. When the CHM is opened by your program it runs in the permissions context of the program, which may not be the same as your Windows account. Try opening the CHM from your program directory by double-clicking on it. You will probably find that the PDF opens from the link then.

If your installer installs all three files -- your program, the CHM file and the PDF file -- my guess is that the link will also work because then all three will be in the same permissions context.
Regards,
Tim (EC Software Documentation & User Support)

Private support:
Please do not email or PM me with private support requests -- post to the forum directly.

mbgg
Posts: 120
Joined: Sun Oct 22, 2006 3:42 pm

Re: Problem with link to PDF file

Unread post by mbgg » Mon May 18, 2020 1:29 pm

Thank for the reply.
Yes, the PDF is displayed after I double-click on the CHM file in my program directory.
I will update our installation set so that the PDF file is installed along with the program and then will check whether or not the problem persists.
Michael

Version 7.3.0 - Build 4180

Post Reply